Search found 21 matches

by philippe_44
Mon Sep 21, 2020 1:07 am
Forum: General Discussion
Topic: change in code location in external flash causes major performances gap
Replies: 1
Views: 353

change in code location in external flash causes major performances gap

Hi - I have a fairly CPU intensive application that works well, but I've noticed that I can have large changes in CPU consumed by the same thread just by changing the mapping of the flash (simply by having a part of code present or not). There is no difference in thread scheduling due to that code b...
by philippe_44
Wed Aug 12, 2020 2:57 am
Forum: IDEs for ESP-IDF
Topic: VSCode & debugging
Replies: 1
Views: 698

VSCode & debugging

Hi - I've finally got VSCode and esp32 installed properly. I can build, download, monitor ... Now I'm facing an issue with debugging. My debug platform works, I'm able to use is running command line outside of VSCode Inside VSCode, openocd is launched succesfully and received a connection when I sta...
by philippe_44
Sun Aug 09, 2020 6:42 am
Forum: General Discussion
Topic: Debugging Stack/heap problems with VisualGDB
Replies: 1
Views: 1455

Re: Debugging Stack/heap problems with VisualGDB

Very late reply, but I can't see in you zip that you have increased stack size. You know that opus takes a fair bit of stack. Try as much as 32k or compile libopus with NONTHREADSAFE_PSEUDOSTACK
by philippe_44
Fri Jul 31, 2020 6:19 am
Forum: ESP-IDF
Topic: Reading IO configuration
Replies: 1
Views: 465

Reading IO configuration

Hi - It might sound a bit a silly question, but is there a way to read/probe IO configuration? The reason is that some part of my large application need to probe HW environment by configuring some IO to I2C and trying to read something. But these IO might already have been configured for another use...
by philippe_44
Sat May 09, 2020 5:37 am
Forum: ESP-IDF
Topic: RMT and infrared on IDF 3.3
Replies: 1
Views: 704

Re: RMT and infrared on IDF 3.3

Replying to my own question ... my bad (to some extend). I was reading the duration0/duration1 value before scaling to µs. So the different is not 7300 vs 9000, but more the fact that the margin should be set to 150µs rather than 20µs. I've tried with different remotes and got the same result ...
by philippe_44
Sat May 09, 2020 4:54 am
Forum: ESP-IDF
Topic: RMT and infrared on IDF 3.3
Replies: 1
Views: 704

RMT and infrared on IDF 3.3

Hi - I guess I'm missing something very obvious but I can't get the RMT driver to work properly in IDF 3.3. I initially tried in my larger project (SW+HW) and as it was not detecting commands I moved to just the rmt_nec_tx_rx example and a WROVER on DevKitC and it still does not work - and it's driv...
by philippe_44
Thu Apr 30, 2020 6:37 am
Forum: Showcase
Topic: Full audio sub-system based on WROVER
Replies: 3
Views: 2792

Re: Full audio sub-system based on WROVER

chegewara wrote:
Thu Apr 30, 2020 6:09 am
This project looks awesome, thanks for sharing. I could buy you a beer or 2 even if i dont build it for myself.
Could you add license or tell us how it can be licensed?

It's free, all sources are available, except when not provided by expressif for a few of their libraries
by philippe_44
Thu Apr 30, 2020 5:41 am
Forum: Showcase
Topic: Full audio sub-system based on WROVER
Replies: 3
Views: 2792

Full audio sub-system based on WROVER

My WROVER-based project for a full audio multi-room system https://github.com/philippe44/SqueezeAMP - 2x20W class-D amp - Logitech Media Server, AirPlay,BT (sink & source) - SPDIF, Analogue-out - Battery or DC-powered (5-20V), recharge & maintain battery - Supports OLED display SSD1306,22,26,27,51, ...
by philippe_44
Tue Feb 04, 2020 4:35 am
Forum: Hardware
Topic: (solved) failing to use external RAM
Replies: 7
Views: 1894

Re: failing to use external RAM

Hi 1- In menuconfig, components, ESP32 specific, SPI RAM config, there you have an item (after you've enabled malloc() in SPIRAM) that sets the max that will *always* be allocated in IRAM first 2- No, malloc uses internal RAM if requested size is above the minimum set in 1-. Now if you only allocate...
by philippe_44
Mon Feb 03, 2020 9:15 am
Forum: Hardware
Topic: GPIO36/39 crosstalk (or still in sensor mode)
Replies: 4
Views: 1670

Re: GPIO36/39 crosstalk (or still in sensor mode)

Hi - Thanks for your help This sounds like a frustrating problem. It doesn't match any known issue that I'm aware of. It is indeed :-) This makes it sound a bit like it might be an electrical issue, rather than anything in the digital logic domain. Is it possible it's actual electrical crosstalk? Ar...

Go to advanced search