Search found 14 matches

by matthew798
Thu Dec 31, 2020 1:08 am
Forum: ESP32 Arduino
Topic: BLE and BluetoothSerial not working together
Replies: 0
Views: 200

BLE and BluetoothSerial not working together

Hi all, I am hoping this is an easy one. I am hoping to use BLE (for blufi, which I have got working nicely) to work at the same time as Bluetooth classic SPP. The goal is to be able to (re)configure wifi at any time while connected to an ELM327 over a bluetooth (to serial) connection. Unfortunately...
by matthew798
Sun Nov 08, 2020 9:07 pm
Forum: ESP-IDF
Topic: esp_https_ota is complaining about "invalid size"
Replies: 4
Views: 568

Re: esp_https_ota is complaining about "invalid size"

Thank chegewara, I saw your issue. I had looked over the issues before but never clicked on yours for whatever reason. The solution was to call esp_log_level_set("*", ESP_LOG_ERROR); Additionally, I had to disableCore0WDT(); because of how my code is set up. I think I'll move things around in order ...
by matthew798
Sun Nov 08, 2020 12:56 pm
Forum: ESP-IDF
Topic: esp_https_ota is complaining about "invalid size"
Replies: 4
Views: 568

Re: esp_https_ota is complaining about "invalid size"

Thanks! That seems to have helped. Now it hangs on writing for a few seconds then spits out: I (33763) esp_https_ota: Starting OTA... I (33763) esp_https_ota: Writing to partition subtype 17 at offset 0x200000 Guru Meditation Error: Core 0 panic'ed (Cache disabled but cached memory region accessed) ...
by matthew798
Sun Nov 08, 2020 4:56 am
Forum: ESP-IDF
Topic: esp_https_ota is complaining about "invalid size"
Replies: 4
Views: 568

esp_https_ota is complaining about "invalid size"

Hi all, I am trying to use esp_https_ota to update my app from an HTTPS server. I verified that my server implementation returns exactly the same response as the python "simpleHTTPServer" that is used in the official examples. I also verified that my TLS information is correct, and the connection su...
by matthew798
Sun Oct 25, 2020 3:48 am
Forum: ESP-IDF
Topic: esp_crc16_be not available in 4.0, what can I use instead?
Replies: 1
Views: 314

esp_crc16_be not available in 4.0, what can I use instead?

I am using platformio with IDF v4.0, and the appropriate arduino libraries as a component. I am hacking and slashing away at the Blufi demo, and have finally gotten my phone to communicate with the esp. I did, however have to do this: uint16_t blufi_crc_checksum(uint8_t iv8, uint8_t *data, int len) ...
by matthew798
Tue Aug 18, 2020 2:51 am
Forum: ESP-IDF
Topic: Partition for large app with OTA support
Replies: 1
Views: 464

Partition for large app with OTA support

Hi all, I've been reading through the docs on partitions and I have a few question. This is what I currently have: # Name, Type, SubType, Offset, Size, Flags nvs, data, nvs, 0x9000, 0x4000, otadata, data, ota, 0xd000, 0x2000, phy_init, data, phy, 0xf000, 0x1000, factory, app, factory, 0x10000, 0x16E...
by matthew798
Wed Aug 12, 2020 5:52 am
Forum: ESP-IDF
Topic: Interrupts not firing at right time after switch from arduino framework to idf with arduino as component
Replies: 0
Views: 362

Interrupts not firing at right time after switch from arduino framework to idf with arduino as component

Recently I decided it was time to switch from using only the arduino framework to using IDF with arduino as a component. In my code I have an interrupt that performs 3 distinct action, one after the other, at very precise times: void IRAM_ATTR ControlPilot::Pulse(void* arg){ TIMERG0.int_clr_timers.t...
by matthew798
Fri Aug 07, 2020 10:00 pm
Forum: ESP-IDF
Topic: 100microsecond timer in esp32
Replies: 10
Views: 13999

Re: 100microsecond timer in esp32

static void timer_isr(void* arg) { TIMERG0.int_clr_timers.t0 = 1; TIMERG0.hw_timer[0].config.alarm_en = 1; // your code, runs in the interrupt } Just wondering why you re-enable the alarm. IIRC When you set TIMERG0.hw_timer[0].config.autoreload it should remain enabled even after the alarm is trigg...
by matthew798
Fri Aug 07, 2020 2:35 pm
Forum: ESP-IDF
Topic: Timer keeps failing when trying to register ISR within an ISR
Replies: 2
Views: 834

Re: Timer keeps failing when trying to register ISR within an ISR

Ah yes, after reading your post I re-read the docs and it is written plain as day. I figure I'll do what you said, have a single ISR with a persistent state between calls. Am I correct in assuming that to set the timer's alarm in an ISR I have to use TIMERG0.hw_timer[0].alarm_high/low?
by matthew798
Fri Aug 07, 2020 3:25 am
Forum: ESP-IDF
Topic: Timer keeps failing when trying to register ISR within an ISR
Replies: 2
Views: 834

Timer keeps failing when trying to register ISR within an ISR

Hi all, I have a timer that I use to trigger 3 different ISRs. So: ISR_1 must run every x uSec, ISR_2 must run every x + 30 uSec, ISR_3 must run every x + y uSec (where y > 30) So I set it up like this: ISR_1 does it's thing then registers ISR_2 on the timer. ISR_2 does the same for ISR_3, and 3 doe...

Go to advanced search