Search found 49 matches

by preetam
Tue Jul 11, 2017 12:11 pm
Forum: General Discussion
Topic: mdns query stuck after continues use
Replies: 0
Views: 833

mdns query stuck after continues use

Hi All,

I am using the mdns query as mentioned in the example and i ran the query for 1200 ticks every 1 second after running for sometimes it get stuck.
Is this a bug?
Thank you,
Paul
by preetam
Wed Jul 05, 2017 10:37 am
Forum: General Discussion
Topic: ESP32 as an Access Point with the ability to store WiFi credentials (and other configurational data)
Replies: 5
Views: 11311

Re: ESP32 as an Access Point with the ability to store WiFi credentials (and other configurational data)

Hi Andrew,

I assume you are storing in nvs using nvs_set_str (as a string) , in that please check whether the string is zero terminated.

Thank you
Paul
by preetam
Sat Jul 01, 2017 11:12 pm
Forum: General Discussion
Topic: mbedtls_net_connect returned -0x42 , need more info
Replies: 4
Views: 3849

Re: mbedtls_net_connect returned -0x42 , need more info

Hi,

I am now able to connect to aws. I have to disable accelerations under Component config → mbedTLS in menuconfig and now able to test the above scenario.

Thank you
Paul
by preetam
Fri Jun 30, 2017 2:15 pm
Forum: General Discussion
Topic: mbedtls_net_connect returned -0x42 , need more info
Replies: 4
Views: 3849

Re: mbedtls_net_connect returned -0x42 , need more info

Hi, Thank you for the suggestion. I tried to reduce the number of Max number of open sockets to 12 and disabled SO_REUSEPORT, now i am not getting "mbedtls_net_connect returned -0x42 " error but instead getting E (227303) aws_iot: failed! mbedtls_ssl_handshake returned -0x2700 E (227303) aws_iot: Un...
by preetam
Thu Jun 29, 2017 3:46 pm
Forum: General Discussion
Topic: mbedtls_net_connect returned -0x42 , need more info
Replies: 4
Views: 3849

mbedtls_net_connect returned -0x42 , need more info

Hi All, I have several tasks running on esp32, in which two of them are socket server and mqtt connection to aws (same as https://github.com/espressif/esp-idf/blob/master/examples/protocols/aws_iot/subscribe_publish/main/subscribe_publish_sample.c) I have enabled SO_REUSEADDR, SO_REUSEPORT and Max n...
by preetam
Thu Jun 29, 2017 9:39 am
Forum: General Discussion
Topic: freeRTOS scheduling on esp32
Replies: 6
Views: 4209

Re: freeRTOS scheduling on esp32

Hi All,

I am able to schedule now properly.
previously a created task acquired a mutex and then got deleted without giving away the mutex back. The same mutex has to be acquired before creating additional tasks. hence sometimes the tasks were created and sometimes not.

Thank you
Paul
by preetam
Wed Jun 28, 2017 9:11 am
Forum: General Discussion
Topic: freeRTOS scheduling on esp32
Replies: 6
Views: 4209

Re: freeRTOS scheduling on esp32

Hi ,

After i get ip, i have tasks creator function to create all tasks with a delay of 50 ticks between each creation.

I am not pinning the tasks to any core.
Thanks
Paul
by preetam
Wed Jun 28, 2017 8:20 am
Forum: General Discussion
Topic: ESP32 WIFI-AP + TCP-Socket-Server
Replies: 5
Views: 4537

Re: ESP32 WIFI-AP + TCP-Socket-Server

Hi, After going through the code i think you might have done this things. you have also commented //socket_server_task(); , remove this comment and try wifi_start_access_point(); socket_server_task(); vTaskDelete(NULL); 1. Checked whether the esp32 SSID is broadcasting. 2. Checked whether your compu...
by preetam
Wed Jun 28, 2017 8:15 am
Forum: General Discussion
Topic: freeRTOS scheduling on esp32
Replies: 6
Views: 4209

freeRTOS scheduling on esp32

Hi All, I am working on multiple tasks, i have around 6 tasks and would like to implement round robbin scheduling as follows. task1 is at priority 6 and task2 to task 6 are at 5. here is what i have done till now in brief. Each task is created after esp32 recieves the IP. Each tasks has log at the s...
by preetam
Wed Jun 28, 2017 7:57 am
Forum: General Discussion
Topic: gdb COM13: No such file or directory.
Replies: 8
Views: 4337

Re: gdb COM13: No such file or directory.

Hi,

Currently after increasing the stack of the task, the Load Prohibition is not arising. I am sure that the issue will arise in the future as i may be passing a null to socket connect. I will post the full log once i come across the same.

Thanks and Regards,
Paul

Go to advanced search