Search found 14 matches

by pushtoopen
Sun Jan 26, 2020 4:35 am
Forum: ESP32 IDF
Topic: ULP binutils missing 'bin' folder
Replies: 0
Views: 172

ULP binutils missing 'bin' folder

Hi all, attempting to install the binutils sub-code for compiling ULP assembly code. The install instructions say to add the 'bin' folder into your $PATH env variable. the issue is, even after running ./configure, make, make install. no bin folder shows up, nither in the main folder, or the binutils...
by pushtoopen
Sun Oct 06, 2019 2:51 pm
Forum: General Discussion
Topic: Dedicated SRAM for each processor?
Replies: 3
Views: 458

Re: Dedicated SRAM for each processor?

Is it toolchain API supported? Or do you have to do some silly stuff to get that to happen?
by pushtoopen
Sun Oct 06, 2019 6:47 am
Forum: General Discussion
Topic: Dedicated SRAM for each processor?
Replies: 3
Views: 458

Dedicated SRAM for each processor?

Hey all, This: https://www.esp32.com/viewtopic.php?t=5450 link is an old conversation talking about how ESP32 can access up to 16MB of additional ram. Additionally it mentions that you can map the 4MB of extra ram location to separate processors. Does this actually exist? Can I map 4MB of SRAM to on...
by pushtoopen
Sun Oct 06, 2019 6:38 am
Forum: General Discussion
Topic: ESP32-D0WD with OV2640 camera.
Replies: 4
Views: 932

Re: ESP32-D0WD with OV2640 camera.

I was able to get esp-CAM it working electrically with this tutorial: https://randomnerdtutorials.com/esp32-cam-video-streaming-face-recognition-arduino-ide/ I use this cable to flash to it: https://www.amazon.com/Converter-Terminated-Galileo-BeagleBone-Minnowboard/dp/B06ZYPLFNB/ref=asc_df_B06ZYPLFN...
by pushtoopen
Wed Sep 11, 2019 2:31 am
Forum: ESP-WHO
Topic: esp-camera returning half pictures when high quality or higher resolution than SVGA
Replies: 3
Views: 3244

Re: esp-camera returning half pictures when high quality or higher resolution than SVGA

This was exactly the issue, Thanks Dzannda! For all those who want to use the basic ESP-WHO ESP-IDF library and control the camera quality output, go into your app_camera.c file and look for the "camera_config_t config;" declaration. This is the real settings for the camera output over i2C to the es...
by pushtoopen
Tue Sep 10, 2019 2:42 am
Forum: ESP-WHO
Topic: esp-camera returning half pictures when high quality or higher resolution than SVGA
Replies: 3
Views: 3244

Re: esp-camera returning half pictures when high quality or higher resolution than SVGA

Thanks for the path forward. I figured thats what it might be but if youre finding success, then likely im not setting things up properly. I amd using the ESP-IDF codebase and not arduino, but i'll use your guidance and see if i cant find something similar in the codebase. If i find a fix i'll post ...
by pushtoopen
Wed Aug 21, 2019 1:09 am
Forum: ESP32 IDF
Topic: esp-tls read error: -76 and errno 11 for OTA esp-idf 4.0
Replies: 1
Views: 588

Re: esp-tls read error: -76 and errno 11 for OTA esp-idf 4.0

I reverted back to esp-idf v3.3-rc and this is no longer an issue. the OTA update over HTTPS completed successfully.

Please note that this is a legitimate failure in the esp-idf 4.0 toolchain.
by pushtoopen
Tue Aug 20, 2019 5:06 pm
Forum: ESP32 IDF
Topic: esp-tls read error: -76 and errno 11 for OTA esp-idf 4.0
Replies: 1
Views: 588

esp-tls read error: -76 and errno 11 for OTA esp-idf 4.0

Hi all, attempting to get the simple_ota_example working and the device seems to have problems mid download of the hello-world.bin that the readme.md suggests using as a sample file. Running: v4.0-dev-1443-g39f090a4f I used the hello_world example and complied the file after running idf.py menuconfi...
by pushtoopen
Fri Aug 09, 2019 12:20 am
Forum: ESP-WHO
Topic: esp-camera returning half pictures when high quality or higher resolution than SVGA
Replies: 3
Views: 3244

esp-camera returning half pictures when high quality or higher resolution than SVGA

Hi all, i've been using the ai thinker esp32-cam and the esp-eye. When requesting images using the standard esp eye, i get what looks like the system gives up and only serves up a portion of the image. The less quality i use and lower resolution, the higher likelyhood i'll recieve the entire image, ...
by pushtoopen
Tue Jan 22, 2019 1:19 am
Forum: ESP32 IDF
Topic: "Can't run interactive configuration inside non-interactive build process"
Replies: 2
Views: 734

Re: "Can't run interactive configuration inside non-interactive build process"

That was it! how did you figure this one out? Thanks.

Fix: ensure "BATCH_BUILD" is not defined as an environment variable in windows, to ensure the above problem does not continue.

Go to advanced search