Computer not detecting ESP 32

170301
Posts: 4
Joined: Tue Jun 18, 2019 1:43 pm

Computer not detecting ESP 32

Postby 170301 » Tue Jun 18, 2019 2:09 pm

Hello everyone, I am a newbie to ESP 32 so please bear with me if this is a stupid question.

The situation is: My computer can't detect the connected ESP 32. The led on the board is on but it doesn't show up in the device manager, not even as an "unrecognized device".

I tried with:
2 USB cables, so it shouldn't be the cable;
3 ESP 32, so it shouldn't be the microcontroller;
4 USB ports, so it shouldn't be the port,
and 2 computers. One with everything installed including the Arduino IDE and the USB driver, one with nothing. Both computers are running Windows 10.

I already tried everything, but still don't know what's wrong. It is always the same situation no matter what I've changed. Does anyone have some ideas?

Any thoughts would be appreciated.

Thanks

ESP_Dazz
Posts: 146
Joined: Fri Jun 02, 2017 6:50 am

Re: Computer not detecting ESP 32

Postby ESP_Dazz » Tue Jun 18, 2019 3:05 pm

If you open your device manager, does it detect the USB connection at all? (i.e. does something show up under "Other Devices"?)

170301
Posts: 4
Joined: Tue Jun 18, 2019 1:43 pm

Re: Computer not detecting ESP 32

Postby 170301 » Tue Jun 18, 2019 3:27 pm

ESP_Dazz wrote:
Tue Jun 18, 2019 3:05 pm
If you open your device manager, does it detect the USB connection at all? (i.e. does something show up under "Other Devices"?)
Nope. That's the issue. If it shows under "Other Devices", then I know it is a driver issue. Nothing changes after I plugged in the ESP 32.

ESP_Dazz
Posts: 146
Joined: Fri Jun 02, 2017 6:50 am

Re: Computer not detecting ESP 32

Postby ESP_Dazz » Wed Jun 19, 2019 10:21 am

Which development board are you using (i.e. is it an official Espressif board or a third party one? If it's third part, any information such as a board schematic or a link would be helpful), and which USB to UART chip does it have (e.g. FT2232 or CP2102)?

obod0002
Posts: 19
Joined: Sat Apr 13, 2019 2:34 pm

Re: Computer not detecting ESP 32

Postby obod0002 » Fri Jun 21, 2019 7:50 am

easiest question that you might already have checked:
are you using the correct cable and not e.g. one designed to only charge USB devices and hence one without the internal data cables?

Maybe you could try with a Linux Live Image which has support already integrated just to validate it's not MS's fault.

Do you have any 'strange' setting in the BIOS of your computers that don't allow external USB drives to be mounted. Sometimes settings are used to prevent from accessing the computer by those USB drives (mostly in companies).

170301
Posts: 4
Joined: Tue Jun 18, 2019 1:43 pm

Re: Computer not detecting ESP 32

Postby 170301 » Mon Jun 24, 2019 5:10 am

Thank you ESP_Dazz and obod0002 for your help. It turns out that it is a stupid question - it is the cable. I borrowed those two cables from my colleague and never thought it would be the cable (because the power LED on board was on). Now I just received my new cable and everything works great. Thank you again. I really appreciate it.

170301
Posts: 4
Joined: Tue Jun 18, 2019 1:43 pm

Re: Computer not detecting ESP 32

Postby 170301 » Mon Jun 24, 2019 2:51 pm

Also, I did some search online before came here and made a new post. There are people mentioning "some cables are just charging cables". But I thought "I already tested two cables, there is no way both of them are charging cable, especially one of them comes with an Android Phone" And at that time, I don't have a device to test the micro USB cable other than my ESP 32. But I still brought a new cable because there is nothing else I can doubt. I finally received my new cable yesterday and, it turns out that the problem is still the old cables.

Thank you again for your help.

Who is online

Users browsing this forum: No registered users and 7 guests