Using ESP-PROGs second channel as UART with enabled JTAG

Baptisto
Posts: 5
Joined: Tue Jun 02, 2020 11:32 am

Using ESP-PROGs second channel as UART with enabled JTAG

Postby Baptisto » Tue Jun 02, 2020 1:36 pm

Hello. Im trying to use FTDI's B channel as UART simultaneously with JTAG on channel A.
On schematic I see no obstacles.
But if im install default drivers on B interface, JTAG stops to work with "libusb_claim_interface() failed with LIBUSB_ERROR_NOT_SUPPORTED"

Can i workaround this? Or in JTAG mode FTDI is fully occupied?

ESP_igrr
Posts: 1656
Joined: Tue Dec 01, 2015 8:37 am

Re: Using ESP-PROGs second channel as UART with enabled JTAG

Postby ESP_igrr » Tue Jun 02, 2020 1:49 pm

Hi Baptisto,

What you are describing should work. The default board config files described in https://docs.espressif.com/projects/esp ... fic-target should take care of using the correct interface.

Baptisto
Posts: 5
Joined: Tue Jun 02, 2020 11:32 am

Re: Using ESP-PROGs second channel as UART with enabled JTAG

Postby Baptisto » Tue Jun 02, 2020 5:07 pm

Im using MVS + VisualGDB.

Wrover devkit seems refers to "esp32 ftdi"
Im checked interface/ftdi/esp32_devkitj_v1.cfg and it seems ok (code below).

It must use interface 0, but when i try to begin debug - it fails, says what interface 0 has no WinUSB drivers (but it has, interface 1 has not).

Code: Select all

interface ftdi
ftdi_vid_pid 0x0403 0x6010

# interface 1 is the uart
ftdi_channel 0
# just TCK TDI TDO TMS, no reset
ftdi_layout_init 0x0008 0x000b
reset_config none

adapter_khz 20000

Baptisto
Posts: 5
Joined: Tue Jun 02, 2020 11:32 am

Re: Using ESP-PROGs second channel as UART with enabled JTAG

Postby Baptisto » Tue Jun 02, 2020 6:33 pm

Ok the problem was what Interface 1 drivers was not "True" FTDI drivers, but Zadig's USB-CDC, they successfuly work as serial port, but someway's conflicting with WinUSB in interface 0.

After installing FTDI's drivers on interface 1 the problem is gone.

Who is online

Users browsing this forum: No registered users and 5 guests