using 32KHz crystal on wrover kit

iotbuilder
Posts: 2
Joined: Mon Jun 08, 2020 4:17 am

using 32KHz crystal on wrover kit

Postby iotbuilder » Mon Jun 08, 2020 4:38 am

Hi,

I am a new user who is using ESP32. I want to use 32KHz for the low power BLE mode.
My setup is as below:
a. Board: ESP32-WROVER-KIT_V4.1
b. IDF version: latest

I am using the example BLEHR in the examples directory.
In menuconfig, I have enabled the following:
a. Modem sleep options --> bluetooth low power clock (32Khz)
b. Ble sleep clock accuracy (251ppm to 500ppm)
c. RTC clock source ( external 32KHz crystal)
d. Also did the following:
[*] Additional current for external 32kHz crystal
(3000) Number of cycles for RTC_SLOW_CLK calibration
(100) Number of attempts to repeat 32k XTAL calibration
(3000) Bootstrap cycles for external 32kHz crystal
(2000) Extra delay in deep sleep wake stub (in us)

I have also made changes to the hardware based on the schematic:
32K-CLK:R36/0R、R37/0R :ON
R38/0R、R39/0R :OFF

Even though, I made the changes, I am not able to get the device switch to 32KHz clock. I get the following error on my terminal:
pm_esp32: Frequency switching config: CPU_MAX: 80, APB_MAX: 80, APB_MIN: 40, Light sleep: DISABLED

I am expecting light sleep current to be < 5ma but it is more as shown in the attached plot.

What else should i do get it to switch 32KHz crystal?

cheers
Attachments
Capture.PNG
Capture.PNG (97.01 KiB) Viewed 442 times

Who is online

Users browsing this forum: No registered users and 11 guests