UART0 do not receive when configured to GPIO03

nkitanov
Posts: 1
Joined: Wed Jun 24, 2020 7:16 am

UART0 do not receive when configured to GPIO03

Postby nkitanov » Wed Jun 24, 2020 7:32 am

Hello all. I have some issue with ESP32 board like this. and try to connect pms7003 dust sensor to GPIO3 which is the same pin where the onboard serial converter is connected. This configuration is not working and I do not receive any data from the sensor. However the same config on ESP8266 works (using hardware UARTRX pin there).

I am using a PCB compatible with wemos d1 min (esp8266) and I need this uart rx on GPIO3, cannot change it easy to another port. Tried changing uart0 rx to be gpio5 and connected directly gpio3 and 5 and it works. So with the same sensor when on gpio5 it works, but not on gpio3. I read the datasheet of esp32 and schematic of the board but still don't get an idea why it's not working. There is no logic. I even tried to directly connect the sensor to esp32-wroom module pin to rule out issues with the PCB but it's the same. It's using PC210x usb-serial converter while on the working d1mini with 8266 serial converter is CH340. This is the only meaningful difference I find.

Gan you give me any idea what can be wrong? Schematic of the d1 compatible board is like this: https://i.imgur.com/EpE4dGj.jpg

Who is online

Users browsing this forum: No registered users and 8 guests