ESP32 D2WD Not Responding to Flash Tool

Brento
Posts: 19
Joined: Mon Apr 20, 2020 10:02 am

ESP32 D2WD Not Responding to Flash Tool

Postby Brento » Sat Jun 27, 2020 2:18 am

I recently designed a new board using the ESP32 D2WD chip. However, I have not been able to communicate with it using the flash_download_tool_3.8.5.exe. I tested this app with a DevkitC board, and it seems to respond fine. Was wondering if anyone can see any issues with the circuit design?

Image

My windows detects the CP2102N driver and tells me it successfully installed the drivers. I tested the power components, and they seem to work properly. However, because of the size of the MCU, I cannot measure at the pins themselves.

Basically, using the Flash Tool>Developer Mode>ESP32D2WD DownloadTool, no files selected, but checkd off SpiAutoSet and DoNotChgBin, I get the following error:

Image

Here is a link to the crystal I am using. AFAIK, I have done everything correct, and triple checked for accuracy. Yet, no response..
https://www.digikey.ca/en/products/deta ... T3/7173271

ESP_Sprite
Posts: 3732
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32 D2WD Not Responding to Flash Tool

Postby ESP_Sprite » Sat Jun 27, 2020 7:26 am

Hard to say, that error tells you the board somehow does not respond and that could be because any of a number of reasons. Can you start a terminal on that com-port (at 115200 baud, 8n1) and reset the ESP32? Do you get output then? Can you manually tie low GPIO0 and reset the ESP32? Does it go into boot mode then and can you flash it?

Brento
Posts: 19
Joined: Mon Apr 20, 2020 10:02 am

Re: ESP32 D2WD Not Responding to Flash Tool

Postby Brento » Sat Jun 27, 2020 9:19 am

Oh hey, yeah I pulled the GPIO0 to ground, and ran the flash tool again. This time it gave me a normalish looking response.

Perhaps the BJTs arent working as expected?

ESP_Sprite
Posts: 3732
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32 D2WD Not Responding to Flash Tool

Postby ESP_Sprite » Sat Jun 27, 2020 5:51 pm

Well, the base of the reset BJT is connected to CTS, which generally is an input... you want to connect it to DTR instead I think, which would be pin 28.

Brento
Posts: 19
Joined: Mon Apr 20, 2020 10:02 am

Re: ESP32 D2WD Not Responding to Flash Tool

Postby Brento » Mon Jun 29, 2020 2:59 am

I managed to flash 3 of the 5 boards by pulling down GPIO0 and GPIO2 when USB power is connected.

Gonna have to look closer into how those BJTs work. I based them off another forum post here, but apparently not the best advice.

However, I created an LED blink program, which works on the Devkit, but the GPIO on this new board doesn't make them blink. I tried GPIO18 and 26, which are unused.

Any explanation why the program can seemingly upload to the D2WD, but nor work properly? I pulled GPIO0 to 3.3V through a 5k resistor, and reconnected power.. no blinks!

Who is online

Users browsing this forum: No registered users and 15 guests