same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

mavros2001
Posts: 5
Joined: Sat Jan 23, 2021 7:54 pm

same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby mavros2001 » Sat Jan 23, 2021 8:25 pm

Hello,

I developed a board that contains esp32, 12v to 5V and 3.3V source(MP1584EN), st232c and DS1307. The PCBs are identical but for those with wroom-32U when using external power, UART0 no longer works properly. Some strange signs and sometimes truncated debug messages appear in the debug window. If I power the board through the USB adapter (5V) the messages come correctly. If I want to program the wroom-32U board and use external power, I can't program. If I use the power from the USB-TTL adapter it is OK.
On wroom-32 boards, debug messages appear correctly and can be programmed no matter what power source I use.
I use the same USB-TTL adapter in all tests.
When I use the board power supply, I disconnect the 5V wire from the USB-TTL adapter.
What is the difference between WROOM-32 and WROOM-32U and how can I solve the problem because I will only use WROOM-32U?
Thank you

ESP_Sprite
Posts: 4396
Joined: Thu Nov 26, 2015 4:08 am

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby ESP_Sprite » Sun Jan 24, 2021 3:38 am

Are you sure you connected the grounds togethet?

mavros2001
Posts: 5
Joined: Sat Jan 23, 2021 7:54 pm

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby mavros2001 » Sun Jan 24, 2021 6:42 am

All the connections, all the cables are the same but different behaviors.

ESP_Sprite
Posts: 4396
Joined: Thu Nov 26, 2015 4:08 am

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby ESP_Sprite » Mon Jan 25, 2021 1:41 am

Well, there is not much difference between the ESP32-wroom-32 and esp-32-wroom-U, they're later revisions iirc but the basic schematic didn't change. Are you sure that there isn't something different between the PCBs, as in a bridged solder connection, or a solder connection that didn't take? Can you perhaps share schematics?

mavros2001
Posts: 5
Joined: Sat Jan 23, 2021 7:54 pm

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby mavros2001 » Mon Jan 25, 2021 8:23 am

I attached the schematic from where I started. I don't use USB to UART on board and I use another Power supply from 12V to 5V (MP1584) and a LDO from 5v to 3.3V. All the PCBs are the same and all the components was planted on the line.
Attachments
ESP32-GATEWAY_Rev_G.pdf
(289.36 KiB) Downloaded 22 times

ESP_Sprite
Posts: 4396
Joined: Thu Nov 26, 2015 4:08 am

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby ESP_Sprite » Tue Jan 26, 2021 1:22 am

Not sure exactly why it would give problems, and extremely not sure why on a 32U but not on a 32, but I'd suspect the logic around D1/D3. If any, you're pulling up an ESP32 pin to 5V (via R35), which is out of spec. Can you check if removing R35/R40 and shorting D1/D3 still gives you the issue?

mavros2001
Posts: 5
Joined: Sat Jan 23, 2021 7:54 pm

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby mavros2001 » Tue Jan 26, 2021 9:05 am

On my PCB I don't use the USB to UART from schematic. I connect an USB to TTL adaptor like this:
TX - GPIO1
RX - GPIO3
RST - ESP_EN
GND - GND + GPIO0

ESP_Sprite
Posts: 4396
Joined: Thu Nov 26, 2015 4:08 am

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby ESP_Sprite » Wed Jan 27, 2021 12:30 am

Clear. Do you still have the on-board USB-to-serial chip connected or did that get removed in the design?

mavros2001
Posts: 5
Joined: Sat Jan 23, 2021 7:54 pm

Re: same PCB, but different behaviors at esp32-wroom-32 and wroom-32U

Postby mavros2001 » Sun Jan 31, 2021 7:36 am

The USB-to-serial chip was removed from board

Who is online

Users browsing this forum: No registered users and 22 guests