Page 1 of 1

HTTPS OTA error: Passive OTA partition not found

Posted: Sat Jul 20, 2019 3:40 pm
by RMandR
I have built and flashed my application using "make flash monitor" (windows 7, ESP_IDF 3.2).

The partition table is as below and I'm getting a "Passive OTA partition not found" after the call to

Code: Select all

 esp_https_ota(&config)
.

What am I doing wrong?

Thanks in adance!

partition.csv

Code: Select all

# Name,   Type, SubType, Offset,  Size, Flags
nvs,      data, nvs,     0x9000,  0x4000,
otadata,  data, ota,     0xd000,  0x2000,
phy_init, data, phy,     0xf000,  0x1000,
factory,  0,    0,       0x10000, 1M,
ota_0,    0,    ota_0,  0x110000, 1M,
ota_1,    0,    ota_1,  0x210000, 1M,
output:

Code: Select all

I (4706) esp_https_ota: Starting OTA...
E (4706) esp_https_ota: Passive OTA partition not found
E (4706) HTTP_CLIENT: Firmware Upgrades Failed

Re: HTTPS OTA error: Passive OTA partition not found

Posted: Mon Jul 22, 2019 1:27 pm
by RMandR
What am I doing wrong?
In case anyone else trips onto this: partition.csv is not read by default.

Code: Select all

" choose “Custom partition table CSV” in menuconfig"

Re: HTTPS OTA error: Passive OTA partition not found

Posted: Mon Jul 22, 2019 7:01 pm
by Ritesh
RMandR wrote:
Sat Jul 20, 2019 3:40 pm
I have built and flashed my application using "make flash monitor" (windows 7, ESP_IDF 3.2).

The partition table is as below and I'm getting a "Passive OTA partition not found" after the call to

Code: Select all

 esp_https_ota(&config)
.

What am I doing wrong?

Thanks in adance!

partition.csv

Code: Select all

# Name,   Type, SubType, Offset,  Size, Flags
nvs,      data, nvs,     0x9000,  0x4000,
otadata,  data, ota,     0xd000,  0x2000,
phy_init, data, phy,     0xf000,  0x1000,
factory,  0,    0,       0x10000, 1M,
ota_0,    0,    ota_0,  0x110000, 1M,
ota_1,    0,    ota_1,  0x210000, 1M,
output:

Code: Select all

I (4706) esp_https_ota: Starting OTA...
E (4706) esp_https_ota: Passive OTA partition not found
E (4706) HTTP_CLIENT: Firmware Upgrades Failed
Hello,

Which Partition table you have selected for OTA example? Because as per error it seems like you are facing issue due to wrong partition table selection that is why OTA is going to fail due to that reason.