ESP32 and eduroam (WPA2 Enterprise)?

Posts: 7
Joined: Thu Feb 15, 2018 3:49 pm

ESP32 and eduroam (WPA2 Enterprise)?

Postby rolobr » Fri Feb 16, 2018 3:34 pm

Hello everyone,

I am very new to the ESP32 and just started discovering it.
As I would like to use it at my university I would like to connect it to eduroam (WPA2 Enterprise).
According to our support, I do not need any certificates. PEAP is used and data is encrypted with AES or TKIP.

I tried to run the WPA2 enterprise demo which is included in the current IDF and I am runninig the current IDF-version.
(Downloaded 2 days ago. I sadly don't know how to find out the actual version)
There I left the original .PEM, .CRT and .KEY files in the project folder and set the mode to PEAP.
I also tried to remove the certificates in the source code as they are not needed in my case as I understood.

In both cases I get a Guru Meditation Error.
For the first, where I had the certificates present I made a core dump.

Do you have any idea how to solve this problem or has anyone a working example how to connect to eduroam using IDF and not Arduino?

Thank you very much for the help!

Here the dump:

Code: Select all

==================== ESP32 CORE DUMP START ====================

================== CURRENT THREAD REGISTERS ===================
pc             0x4012c535	0x4012c535 <mp_read_unsigned_bin+45>
lbeg           0x4000c46c	1073792108
lend           0x4000c477	1073792119
lcount         0x0	0
sar            0x18	24
ps             0x60c20	396320
threadptr      <unavailable>
br             <unavailable>
scompare1      <unavailable>
acclo          <unavailable>
acchi          <unavailable>
m0             <unavailable>
m1             <unavailable>
m2             <unavailable>
m3             <unavailable>
expstate       <unavailable>
f64r_lo        <unavailable>
f64r_hi        <unavailable>
f64s           <unavailable>
fcr            <unavailable>
fsr            <unavailable>
a0             0x4012d270	1074975344
a1             0x3ffc6a10	1073506832
a2             0x3ffc8a14	1073515028
a3             0x1	1
a4             0x3ffcade4	1073524196
a5             0x3ffcade3	1073524195
a6             0x2	2
a7             0x5	5
a8             0x8012c533	-2146253517
a9             0x3ffc69f0	1073506800
a10            0x0	0
a11            0x8	8
a12            0x3ffc8a14	1073515028
a13            0x0	0
a14            0x43204c53	1126190163
a15            0x10	16

==================== CURRENT THREAD STACK =====================
#0  mp_read_unsigned_bin (a=0x3ffc8a14, b=0x2 <error: Cannot access memory at address 0x2>, c=1073524195) at /home/roland/esp/esp-idf/components/wpa_supplicant/src/crypto/libtommath.h:990
#1  0x4012d270 in bignum_set_unsigned_bin (n=0x3ffc8a14, buf=0x1 <error: Cannot access memory at address 0x1>, len=1074975344) at /home/roland/esp/esp-idf/components/wpa_supplicant/src/crypto/bignum.c:114
#2  0x4012bce5 in crypto_mod_exp (base=0x1 <error: Cannot access memory at address 0x1>, base_len=1073524196, power=0x3ffcade8 <error: Cannot access memory at address 0x3ffcade8>, power_len=1073507028, modulus=0x3ffc6b04 \"3\", modulus_len=1061217260, result=0x2 <error: Cannot access memory at address 0x2>, result_len=0x10) at /home/roland/esp/esp-idf/components/wpa_supplicant/src/crypto/crypto_internal-modexp.c:40
#3  0x4010e5d4 in x509_certificate_check_signature ()
#4  0x4010e7ce in x509_certificate_chain_validate ()
#5  0x4010b46d in ?? ()
#6  0x4010b864 in tlsv1_client_process_handshake ()
#7  0x4010aad0 in tlsv1_client_handshake ()
#8  0x4010a539 in tls_connection_handshake2 ()
#9  0x4010a59c in tls_connection_handshake ()
#10 0x40108b4b in eap_peer_tls_process_helper ()
#11 0x4010827d in ?? ()
#12 0x40106758 in eap_sm_process_request ()
#13 0x40106abc in wpa2Task ()

======================== THREADS INFO =========================
  Id   Target Id         Frame 
  10   process 9         0x40088e71 in xQueueGenericReceive (xQueue=0x3ffafd28, pvBuffer=0x0, xTicksToWait=4294967295, xJustPeeking=0) at /home/roland/esp/esp-idf/components/freertos/./queue.c:1591
  9    process 8         0x40088e71 in xQueueGenericReceive (xQueue=0x3ffbd544, pvBuffer=0x3ffbeb40, xTicksToWait=4294967295, xJustPeeking=0) at /home/roland/esp/esp-idf/components/freertos/./queue.c:1591
  8    process 7         0x40088e71 in xQueueGenericReceive (xQueue=0x3ffc2d20, pvBuffer=0x3ffc3790, xTicksToWait=4294967295, xJustPeeking=0) at /home/roland/esp/esp-idf/components/freertos/./queue.c:1591
  7    process 6         0x40088e71 in xQueueGenericReceive (xQueue=0x3ffaea14, pvBuffer=0x0, xTicksToWait=4294967295, xJustPeeking=0) at /home/roland/esp/esp-idf/components/freertos/./queue.c:1591
  6    process 5         0x40088e71 in xQueueGenericReceive (xQueue=0x3ffbc19c, pvBuffer=0x3ffbd130, xTicksToWait=4294967295, xJustPeeking=0) at /home/roland/esp/esp-idf/components/freertos/./queue.c:1591
  5    process 4         0x4008a81c in prvProcessTimerOrBlockTask (xNextExpireTime=<optimized out>, xListWasEmpty=<optimized out>) at /home/roland/esp/esp-idf/components/freertos/./timers.c:588
  4    process 3         0x40088e71 in xQueueGenericReceive (xQueue=0x3ffbb42c, pvBuffer=0x3ffbbec0, xTicksToWait=100, xJustPeeking=0) at /home/roland/esp/esp-idf/components/freertos/./queue.c:1591
  3    process 2         0x40089b72 in vTaskDelay (xTicksToDelay=<optimized out>) at /home/roland/esp/esp-idf/components/freertos/./tasks.c:1491
  2    process 1         0x400d1d4e in esp_vApplicationIdleHook () at /home/roland/esp/esp-idf/components/esp32/./freertos_hooks.c:62
* 1    <main task>       mp_read_unsigned_bin (a=0x3ffc8a14, b=0x2 <error: Cannot access memory at address 0x2>, c=1073524195) at /home/roland/esp/esp-idf/components/wpa_supplicant/src/crypto/libtommath.h:990

======================= ALL MEMORY REGIONS ========================
Name   Address   Size   Attrs
.rtc.text 0x400c0000 0x0 RW  
.iram0.vectors 0x40080000 0x400 R XA
.iram0.text 0x40080400 0xd9dc R XA 0x3ffb0000 0x2a5c RW A
.flash.rodata 0x3f400020 0x13d04 RW A
.flash.text 0x400d0018 0x6273c R XA
.coredump.tasks 0x3ffb8fe0 0x174 RW 
.coredump.tasks 0x3ffc6950 0x5a0 RW 
.coredump.tasks 0x3ffba0c8 0x174 RW 
.coredump.tasks 0x3ffb9f60 0x160 RW 
.coredump.tasks 0x3ffc537c 0x174 RW 
.coredump.tasks 0x3ffc51f0 0x184 RW 
.coredump.tasks 0x3ffbbf58 0x174 RW 
.coredump.tasks 0x3ffbbd70 0x1e0 RW 
.coredump.tasks 0x3ffbab38 0x174 RW 
.coredump.tasks 0x3ffba9b0 0x180 RW 
.coredump.tasks 0x3ffbd1f4 0x174 RW 
.coredump.tasks 0x3ffbd030 0x1bc RW 
.coredump.tasks 0x3ffafa6c 0x174 RW 
.coredump.tasks 0x3ffaf8e0 0x184 RW 
.coredump.tasks 0x3ffc382c 0x174 RW 
.coredump.tasks 0x3ffc3690 0x194 RW 
.coredump.tasks 0x3ffbebdc 0x174 RW 
.coredump.tasks 0x3ffbea30 0x1a4 RW 
.coredump.tasks 0x3ffafd7c 0x174 RW 
.coredump.tasks 0x3ffb87c0 0x180 RW 

===================== ESP32 CORE DUMP END =====================

Who is online

Users browsing this forum: No registered users and 45 guests