esp-idf The following Python requirements are not satisfied: future>=0.16.0

gigijoe
Posts: 20
Joined: Wed Aug 02, 2017 10:16 am

esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby gigijoe » Mon Sep 03, 2018 4:04 am

After update esp-idf today, I'm no longer make my project due to missing python package
The following Python requirements are not satisfied:
future>=0.16.0
Please run "/usr/bin/python -m pip install -r /home/gigijoe/ESP32/esp-idf/requirements.txt" for resolving the issue.
make: *** [check_python_dependencies] Error 1
/usr/bin/python -m pip install -r /home/gigijoe/ESP32/esp-idf/requirements.txt
/usr/bin/python: No module named pip.__main__; 'pip' is a package and cannot be directly executed
I also try
pip install -r requirements.txt
Requirement already satisfied (use --upgrade to upgrade): pyserial>=3.0 in /usr/local/lib/python2.7/dist-packages (from -r requirements.txt (line 4))
Downloading/unpacking future>=0.16.0 (from -r requirements.txt (line 5))
Cannot fetch index base URL http://pypi.python.org/simple/
Could not find any downloads that satisfy the requirement future>=0.16.0 (from -r requirements.txt (line 5))
No distributions at all found for future>=0.16.0 (from -r requirements.txt (line 5))
Storing complete log in /home/gigijoe/.pip/pip.log
My working environment is PC Ubuntu 12.04. Any idea ?

ESP_Angus
Posts: 1609
Joined: Sun May 08, 2016 4:11 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby ESP_Angus » Mon Sep 03, 2018 4:30 am

Hi gigijoe,

The Pypi server now requires HTTPS, which very old versions of pip do not use.

You can work around this situation by running:

Code: Select all

pip install --index-url=https://pypi.python.org/simple/ -r requirements.txt
(as suggested here.)

Please note that Ubuntu 12.04 has been officially End Of Life since April 2017. No updates (including security updates) are provided by Canonical, which is why pip is no longer working. You may want to consider upgrading to the latest Ubuntu Long Term Support release.

gigijoe
Posts: 20
Joined: Wed Aug 02, 2017 10:16 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby gigijoe » Mon Sep 03, 2018 4:49 am

Hello Angus

The work around works for me, thank you.
I know 12.04 is old, but I still need to maintain other old projects with it. It's just too dangerous to upgrade any thing.

Reiner1210
Posts: 21
Joined: Tue Mar 20, 2018 6:28 pm

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby Reiner1210 » Thu Sep 06, 2018 11:07 am

On Linux Mint 19 - there is no future 0.16 available in the repositories
I tried
pip install --index-url=https://pypi.python.org/simple/ -r requirements.txt

which does not work .... and now - how can I disable the test ?


Requirement already satisfied: pyserial>=3.0 in /usr/lib/python2.7/dist-packages (from -r requirements.txt (line 4))
Collecting future>=0.16.0 (from -r requirements.txt (line 5))
Downloading https://files.pythonhosted.org/packages ... 6.0.tar.gz (824kB)
100% |████████████████████████████████| 829kB 514kB/s
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
ImportError: No module named setuptools

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /tmp/pip-build-jWL2ib/future/

ESP_Angus
Posts: 1609
Joined: Sun May 08, 2016 4:11 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby ESP_Angus » Thu Sep 06, 2018 11:35 am

Reiner1210 wrote:On Linux Mint 19 - there is no future 0.16 available in the repositories
I tried
pip install --index-url=https://pypi.python.org/simple/ -r requirements.txt

which does not work .... and now - how can I disable the test ?
You can edit the test script to disable it, but if the "future" package isn't installed then you'll get other (weirder) Python errors instead. The test script exists to try and smooth the path past those errors. :)

I'm surprised you can have "pip" but not "setuptools", I didn't realise this was possible - we may need to add another check somewhere. You may be able to run this:

Code: Select all

sudo apt-get install python-future
If this doesn't work, try running

Code: Select all

sudo apt-get install python-setuptools
pip install --index-url=https://pypi.python.org/simple/ -r requirements.txt
I think one of these two options will succeed for Mint 19.

Reiner1210
Posts: 21
Joined: Tue Mar 20, 2018 6:28 pm

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby Reiner1210 » Wed Sep 12, 2018 10:28 pm

Yes!
I also needed
<code> pip install --upgrade pip</code>

ESP_Angus
Posts: 1609
Joined: Sun May 08, 2016 4:11 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby ESP_Angus » Thu Sep 13, 2018 12:03 am

Great news! We've added "setuptools" as a prerequisite to the Getting Started guides and to requirements.txt itself, now that we know it may not be installed on all systems.

FluxGS
Posts: 11
Joined: Sun Mar 18, 2018 7:01 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby FluxGS » Mon Oct 01, 2018 4:41 am

I am also having this problem on my installation today.
I am using Windows 10 and have followed the Get Started for Stable Version V3.1

!!! Completed Toolchain Setup
The quick setup is to download the Windows all-in-one toolchain & MSYS2 zip file from dl.espressif.com:
https://dl.espressif.com/dl/esp32_win32 ... 180110.zip
Unzip the zip file to C:\

!!! Completed
mkdir -p ~/esp

!!! Completed
cd ~/esp
git clone -b v3.1 --recursive https://github.com/espressif/esp-idf.git

!!! Set IDF_PATH

!!! Installed esp-idf-template example

!!! Error occurs on the make for the template example; see error below:

$ make
Toolchain path: /opt/xtensa-esp32-elf/bin/xtensa-esp32-elf-gcc
Toolchain version: crosstool-ng-1.22.0-80-g6c4433a
Compiler version: 5.2.0
The following Python requirements are not satisfied:
future>=0.16.0
cryptography
Please run "C:/msys32/mingw32/bin/python.exe -m pip install --user -r C:/msys32/home/RogueOne/esp/esp-idf/requirements.txt" for resolving the issue.
make: *** [C:/msys32/home/RogueOne/esp/esp-idf/make/project.mk:454: check_python_dependencies] Error 1

!!! Following suggestion for requirements yields the following:

$ pip install --index-url=https://pypi.python.org/simple/ -r esp/esp-idf/requirements.txt
Looking in indexes: https://pypi.python.org/simple/
Requirement already satisfied: setuptools in c:/msys32/mingw32/lib/python2.7/site-packages (from -r esp/esp-idf/requirements.txt (line 4)) (40.4.3)
Requirement already satisfied: pyserial>=3.0 in c:/msys32/mingw32/lib/python2.7/site-packages (from -r esp/esp-idf/requirements.txt (line 8)) (3.1.1)
Collecting future>=0.16.0 (from -r esp/esp-idf/requirements.txt (line 9))
Using cached https://files.pythonhosted.org/packages ... 6.0.tar.gz
Complete output from command python setup.py egg_info:
Traceback (most recent call last):
File "<string>", line 1, in <module>
File "C:/msys32/mingw32/lib/python2.7/site-packages/setuptools/__init__.py", line 191, in <module>
monkey.patch_all()
File "C:/msys32/mingw32/lib/python2.7/site-packages/setuptools/monkey.py", line 101, in patch_all
patch_for_msvc_specialized_compiler()
File "C:/msys32/mingw32/lib/python2.7/site-packages/setuptools/monkey.py", line 164, in patch_for_msvc_specialized_compiler
patch_func(*msvc9('find_vcvarsall'))
File "C:/msys32/mingw32/lib/python2.7/site-packages/setuptools/monkey.py", line 151, in patch_params
mod = import_module(mod_name)
File "C:/msys32/mingw32/lib/python2.7/importlib/__init__.py", line 37, in import_module
__import__(name)
File "C:/msys32/mingw32/lib/python2.7/distutils/msvc9compiler.py", line 306, in <module>
raise DistutilsPlatformError("VC %0.1f is not supported by this module" % VERSION)
distutils.errors.DistutilsPlatformError: VC 6.0 is not supported by this module

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in c:/users/rogueone/appdata/local/temp/pip-install-kpbg5t/future/

ESP_Angus
Posts: 1609
Joined: Sun May 08, 2016 4:11 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby ESP_Angus » Mon Oct 01, 2018 5:08 am

FluxGS, please try running these 4 commands in order (for Windows/MSYS2):

Code: Select all

python -m pip uninstall -y setuptools
pacman -S mingw-w64-i686-python2-setuptools
pacman -S mingw-w64-i686-python2-cryptography
python -m pip install --user -r $IDF_PATH/requirements.txt
An updated version of the MSYS2 environment, which doesn't need these steps, will be available ASAP.

EDIT: Fixed order of uninstall and -y

FluxGS
Posts: 11
Joined: Sun Mar 18, 2018 7:01 am

Re: esp-idf The following Python requirements are not satisfied: future>=0.16.0

Postby FluxGS » Mon Oct 01, 2018 3:26 pm

Thank you for your quick response ESP_Angus.

The results of your suggestions were not successful.

You recommended:
python -m pip -y uninstall setuptools
pacman -S mingw-w64-i686-python2-setuptools
pacman -S mingw-w64-i686-python2-cryptography
python -m pip install --user -r $IDF_PATH/requirements.txt

$ first line resulted in an error that -y is an invalid parameter. I ran the same command without -y
$ second line: $pacman -S mingw-w64-i686-python2-setuptools: ran to completion
Third line failed:
$ pacman -S mingw-w64-i686-python2-cryptography
error: target not found: mingw-w64-i686-python2-cryptography

Who is online

Users browsing this forum: Baidu [Spider] and 7 guests