rosserial unable to work with ESP32

MrOngCW
Posts: 4
Joined: Sun Jan 02, 2022 1:27 pm

rosserial unable to work with ESP32

Postby MrOngCW » Sun Jan 23, 2022 4:44 pm

Hi, I am trying to use rosserial on ESP32 but I am getting this error on the Serial Monitor (using PlatformIO) when not connected to WiFi.
rst:0xc (SW_CPU_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:2
load:0x3fff0018,len:4
load:0x3fff001c,len:1044
load:0x40078000,len:10124
load:0x40080400,len:5828
entry 0x400806a8
assertion "Invalid mbox" failed: file "/home/runner/work/esp32-arduino-lib-builder/esp32-arduino-lib-builder/esp-idf/components/lwip/lwip/src/api/tcpip.c", line 374, function: tcpip_send_msg_wait_sem
abort() was called at PC 0x400d6a97 on core 1

ELF file SHA256: 0000000000000000

Backtrace: 0x40085020:0x3ffb1dc0 0x4008529d:0x3ffb1de0 0x400d6a97:0x3ffb1e00 0x400ee007:0x3ffb1e30 0x400edaa1:0x3ffb1e60 0x400edc54:0x3ffb1e80 0x400e5ed4:0x3ffb1ec0 0x400d338c:0x3ffb1ee0 0x400d2c4e:0x3ffb1f40 0x400d2619:0x3ffb1f70 0x400d4f6e:0x3ffb1fb0 0x400862ae:0x3ffb1fd0

Rebooting...
ets Jul 29 2019 12:21:46
However, if i first connect to WiFi, then I get
Connecting to WiFi .......
Success!
ESP32 assigned IP address:XXX.XXX.X.XXX

[E][WiFiClient.cpp:258] connect(): socket error on fd 54, errno: 113, "Software caused connection abort"
[E][WiFiClient.cpp:258] connect(): socket error on fd 55, errno: 113, "Software caused connection abort"
[E][WiFiClient.cpp:258] connect(): socket error on fd 56, errno: 113, "Software caused connection abort"
[E][WiFiClient.cpp:258] connect(): socket error on fd 57, errno: 113, "Software caused connection abort"
[E][WiFiClient.cpp:258] connect(): socket error on fd 58, errno: 113, "Software caused connection abort"
...
...
Also, during upload, i realised that the baud rate is changed?
Chip is ESP32-D0WDQ6-V3 (revision 3)
Features: WiFi, BT, Dual Core, 240MHz, VRef calibration in efuse, Coding Scheme None
Crystal is 40MHz
MAC: c8:c9:a3:fa:b4:34
Uploading stub...
Running stub...
Stub running...
Changing baud rate to 460800
Changed.
Is this change of baud rate of any significance?

Thanks!

Who is online

Users browsing this forum: No registered users and 12 guests