ESP32 and MAX7219 daisy chain problem

KrisRevi
Posts: 3
Joined: Sun Mar 29, 2020 12:28 pm

ESP32 and MAX7219 daisy chain problem

Postby KrisRevi » Fri Apr 03, 2020 1:58 pm

this is driving me NUTS..... having trouble with my MAX7219 dot led matrix daisy chain of 32 (running on my ESP32).... the text appear on the display but then randomly portion / half / 80% of the display goes black and sometimes one of the letters/screen just turns to garbled text :S i JUST tried a level shifter (3.3v to 5v) to make the CLK and DATA signal stronger (as suggested on some forums) but sadly didn't work.

Board : DOIT ESP32 DEVKIT V1
Display : MAX7219 (32 in daisy chain)
Pins :
CLK_PIN 18
DATA_PIN 23
CS_PIN 5

here i have the level shifter on CLK and DATA
Image

just a close up on the level shifter
Image

so when i first run it, it works fine
Image

but after a while half or 80% off the display turns off but i can still see that text is updated
Image

something to mention tho is, i wrote a "text line" that was enough to cover 22 modules and it worked fine! no glitch, garbled text or display turning off...

ESP_Sprite
Posts: 3469
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32 and MAX7219 daisy chain problem

Postby ESP_Sprite » Fri Apr 03, 2020 3:25 pm

What exactly is 'after a while'? Is it reproducably the same time every time, or does it differ? I'm wondering if it could be a thermal issue... I also seem to remember that chips like the MAX7219 sometimes are faked, so where did you obtain them, from a reputable source like Digikey or from an Aliexpress shop? Can you look at the SPI signal after the place where the chain breaks?

KrisRevi
Posts: 3
Joined: Sun Mar 29, 2020 12:28 pm

Re: ESP32 and MAX7219 daisy chain problem

Postby KrisRevi » Fri Apr 03, 2020 3:33 pm

it's just after some time it differs (everything from 1min to 15min) and so does the result, sometime random text/letters disapear, sometimes 80% of the display goes black (as you can see in the picture)

i bought these from "banggood.com" :P i know not exactly "BANG GOOD"!! :P all i have is a multimeter...

ESP_Sprite
Posts: 3469
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32 and MAX7219 daisy chain problem

Postby ESP_Sprite » Sat Apr 04, 2020 11:12 am

Sounds like your modules/chips are wonky then. Sorry, without a scope this will get pretty hard to debug...

Who is online

Users browsing this forum: No registered users and 2 guests