ESP32-S2 problem with RMTWriteNeoPixel.ino example

-Rudy-
Posts: 21
Joined: Sun Feb 05, 2017 1:08 am

ESP32-S2 problem with RMTWriteNeoPixel.ino example

Postby -Rudy- » Sat Jun 20, 2020 8:19 pm

I am trying to use the RMTWriteNeoPixel.ino example on a Saola development board. I am not getting the expected behavior.

https://github.com/espressif/arduino-es ... oPixel.ino

With a regular ESP32 (not S2) each led is turned on for 100mS, followed by the next led, then the next, ...

With the ESP32-S2 I get three leds turn on, the first (blue), the second (blue), the third (green), then nothing until the cycle starts over again. The remaining leds in the string are not turned on.

Does anyone know what i need to do to get the Neopixel string to work properly with the ESP32-S2?

-Rudy-
Posts: 21
Joined: Sun Feb 05, 2017 1:08 am

Re: ESP32-S2 problem with RMTWriteNeoPixel.ino example

Postby -Rudy- » Sun Jun 21, 2020 3:33 pm

I looked at the output of the ESP32-S2 with a logic analyser and the number of pulses was 62 with a total time of 73.6uS. The same example file with the ESP32 produced many more pulses with a total time of 921uS.
ESP32-S2_Neopixel.png
ESP32-S2 output.
ESP32-S2_Neopixel.png (20.82 KiB) Viewed 427 times

chegewara
Posts: 1211
Joined: Wed Jun 14, 2017 9:00 pm

Re: ESP32-S2 problem with RMTWriteNeoPixel.ino example

Postby chegewara » Sun Jun 21, 2020 4:54 pm

Yes, it is confirmed arduino bug. Thanks for reporting it.

Who is online

Users browsing this forum: kostuch and 9 guests