esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

hml9083@hotmail.com
Posts: 16
Joined: Mon Nov 30, 2015 12:58 pm

esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby hml9083@hotmail.com » Wed Jan 24, 2018 1:33 pm

i am using the Arduino IDE and can upload my code to my ESP32 boards,
My WiFi code connects to my home network and the board responds as expected,
However after a few minutes to maybe a few hours the ESP32 stops responding,
IE: "Hmmm...can’t reach this page" appears when trying to access the url.
I have tried different ESP32 boards and I get the same problem, I am using unedited basic
code examples such as SimpleWiFiServer or WiFiClient and even basic WiFi code,
where I only change the SSID and Password, it will fail after a few minutes to a few hours
My ESP8266's will run and are available continuously even thru millis roll over...
Any help please.

tele_player
Posts: 90
Joined: Sun Jul 02, 2017 3:38 am

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby tele_player » Thu Jan 25, 2018 9:21 pm

Things I would try:
- leave serial monitor connected, add a Serial.print to loop(), displaying a time stamp every second.
When device becomes unavailable, is timestamp still incrementing?

- when device becomes unavailable, does it still respond to ping?

- when device is unavailable, does it still appear connected in your WiFi base station?

These are just some things to help determine what stopped working.

hml9083@hotmail.com
Posts: 16
Joined: Mon Nov 30, 2015 12:58 pm

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby hml9083@hotmail.com » Fri Jan 26, 2018 2:03 pm

Thank you for your interest.
I have altered SimpleWebServer.ino sketch with my SSID, my Password
and to print out uptime in seconds and RSSI.
note: same problem occurs if I do not add uptime and RSSI,
Webpage is accessible for approximately 2 to 10 minutes.
My RSSI value is -39 to -41, MCU is very close to router.
when page is not accessible
Serial print continues to print RSSI values it does not change
and uptime still increments.

On web page that failed to load, I checked the following,
Windows Network Diagnostics error:
website (192.168.0.192) is online but isn't responding to connection attempts.
Detected

The Failed Webpage message: Can't reach this page.
I am using Windows 10,
Windows Network Diagnostics message is,
The remote computer isn’t responding to connections on port 80,
possibly due to firewall or security policy settings,
or because it might be temporarily unavailable.
Windows couldn’t find any problems with the firewall on your computer.

Another test: I disconnected ESP32 from laptop,
Then powered it using USB power adapter (2 AMP),
I also connected USB adapter to my UPS for clean power supply.
ESP32 boots and connects to home network.
I have opened command window on laptop and started continuous pings,
to ESP32 assigned IP address,
I get replies but fails after 2 to 10 minutes,
message in command window is Request timed out.

I am using,
Arduino IDE: 1.8.2
Espressif SdkVersion: v2.0-rc1-803-g1e0710f1
ESP32 Chip Revision (official version): 0

I have also replaced my router and problem has followed me.
The ESP8266's I have connected to my network, do not have this behavior.

Any help appreciated

tele_player
Posts: 90
Joined: Sun Jul 02, 2017 3:38 am

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby tele_player » Sun Jan 28, 2018 5:01 am

Interesting, and I can’t think of an explanation. I’ll try to duplicate it here.

When it becomes unavailable, does reset get it back, or does it need power cycle?

Update: mine has been running about 12 hours, no problem connecting, continuous ping with no missed responses. No problem accessing the web server.

Arduino 1.8.2 Mac OSX 10.11.6
SDK Version: v3.0-dev-745-gc4e65d6a
Board is a Nodemcu 32, built using 'Board: Node32s'
ESP.getChipRevision() = 1

hml9083@hotmail.com
Posts: 16
Joined: Mon Nov 30, 2015 12:58 pm

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby hml9083@hotmail.com » Mon Jan 29, 2018 4:33 pm

When I use ESP.getChipRevision() in a sketch the serial output is,
ESP.getChipRevision() = 0

When I use the SimpleWiFiServer.ino sketch
and when "Hmmm...can’t reach this page" web page appears
My serial output will display the following,

client disonnected
[D][WiFiGeneric.cpp:182] _eventCallback(): Event: 5 - STA_DISCONNECTED
[W][WiFiGeneric.cpp:187] _eventCallback(): Reason: 9 - ASSOC_NOT_AUTHED

hml9083@hotmail.com
Posts: 16
Joined: Mon Nov 30, 2015 12:58 pm

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby hml9083@hotmail.com » Mon Jan 29, 2018 5:21 pm

Sorry I did not respond to
When it becomes unavailable, does reset get it back, or does it need power cycle?
I have to power cycle or use the reset button,
then ESP32 will reconnect but drop wifi after short period of time.

tele_player
Posts: 90
Joined: Sun Jul 02, 2017 3:38 am

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby tele_player » Mon Jan 29, 2018 7:12 pm

Well, we are running different SDK version, and different hardware revision. I don’t know if either of these can explain what you are seeing.

hml9083@hotmail.com
Posts: 16
Joined: Mon Nov 30, 2015 12:58 pm

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby hml9083@hotmail.com » Thu Feb 01, 2018 7:48 pm

the serial output,
Event code "[W][WiFiGeneric.cpp:187] _eventCallback(): Reason: 9 - ASSOC_NOT_AUTHED"
My network name contains a dash or hyphen,
My Network password is 17 characters in length only letters and digits.
imply my WiFi password is a problem ?

tele_player
Posts: 90
Joined: Sun Jul 02, 2017 3:38 am

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby tele_player » Thu Feb 01, 2018 9:39 pm

Since the disconnect happens after the connection works for some time, I would not think there is anything inherently wrong with your password.

hml9083@hotmail.com
Posts: 16
Joined: Mon Nov 30, 2015 12:58 pm

Re: esp32 running basic WiFi code, I get "Hmmm...can’t reach this page"

Postby hml9083@hotmail.com » Wed Feb 21, 2018 4:11 pm

tele_player thank you for your input and assist, I am not sure why but I been connected and accessing the ESP32 for three days period, The only change I am aware of is recent windows 10 update on my laptop. Thanks for your inspiration.

Who is online

Users browsing this forum: No registered users and 16 guests