Unable to read from BME280

User avatar
rudi ;-)
Posts: 1563
Joined: Fri Nov 13, 2015 3:25 pm

Re: Unable to read from BME280

Postby rudi ;-) » Fri Dec 09, 2016 11:04 am

ESP_Me-no-dev wrote:Just committed this: https://github.com/espressif/arduino-es ... a27e3b6012
I hope it helps :)
txs! great and nice teamwork!
this together work make best fun.

best wishes
rudi ;-)
love it, change it or leave it.

Posts: 70
Joined: Mon Feb 15, 2016 1:35 am

Re: Unable to read from BME280

Postby onehorse » Sun Dec 11, 2016 8:00 pm

Just tried the new commit with my MPU9250+MS5637 and i see the same problem. Posted an new issue on the github site.

Posts: 10
Joined: Sun Nov 20, 2016 12:09 am

Re: Unable to read from BME280

Postby dldtechnology » Mon Dec 12, 2016 9:51 pm

I now have my version of the driver working with various I2C devices at 100K, but it took some doing. Still not working at 400K but that could be electrical as I had quite a lot of stuff on the bus.

I ended up writing some dedicated getByte / getWord functions to combine the write and receive parts into one bit - this seemed to help as I'm not convinced the existing read function is working 100%.

Also changed the timings to make the repeated start look a bit cleaner (don't think this is needed, but made the logic traces look nice).

No problem sharing my code if needed - but it will need changing to make it work with the Arduino environment, and I can't guarantee it will work with all devices.

Posts: 23
Joined: Fri Dec 02, 2016 4:56 pm

Re: Unable to read from BME280

Postby shadow » Wed Dec 14, 2016 10:34 pm

Now that ticket #90 was fixed, I can read the sensor values :)
Would be nice now to find out why they are a couple degrees too big for temperature.

User avatar
Posts: 1683
Joined: Mon Nov 16, 2015 4:43 pm
Location: Texas, USA

Re: Unable to read from BME280

Postby kolban » Wed Dec 14, 2016 11:28 pm

I too would like to confirm that using the Arduino distribution as of the date of this post, my BMP180 is now reading correctly. However the I2C scanner that used to work is now reporting that there is a device on ALL possible I2C addresses. The author of the Arduino package has been informed and is thinking it over.

Later .... the dev of Arduino pushed a new commit that has resolved the I2C scanner issue. From where I sit, I have ZERO open issues with I2C and (for me) all is now working.
Free book on ESP32 available here: https://leanpub.com/kolban-ESP32

Posts: 1
Joined: Tue Jun 30, 2020 6:29 pm

Re: Unable to read from BME280

Postby bucbowie » Tue Jun 30, 2020 6:34 pm

Hi, I am using an ESP32 Wroom-32 with an Adafruit BME280 sensor and a TEMT6000 sensor powered by a 5V 2A adapter. It would hang or stop running after 12 hours. I changed to a power supply of 5V 3A and problem solved. I hope you all find this useful.

Who is online

Users browsing this forum: No registered users and 27 guests