Esp not connecting to wifi after some days

burkulesomesh43
Posts: 132
Joined: Tue Aug 14, 2018 6:21 am
Location: India

Esp not connecting to wifi after some days

Postby burkulesomesh43 » Fri May 03, 2019 1:26 pm

Hello everyone,
I am getting wifi disconnect issue from very long time.
As I kept my ESP32 live for long time, it disconnects and not getting connected to the configured SSID and PASSWORD again till switch it OFF and ON again. I am using esp-idf v3.1.3.

Please help me to resolve this issue.
Thanks in advance.
--
Somesh Burkule

reivax2
Posts: 1
Joined: Sat May 04, 2019 6:05 pm

Re: Esp not connecting to wifi after some days

Postby reivax2 » Sat May 04, 2019 6:14 pm

WiFi.begin(ssid, password);
int i=0;
while (WiFi.status() != WL_CONNECTED && i++<=10)
{
delay(1000);
i=i+1;
if (i>11)
{Serial.print("I don´t connect......");
ESP.restart();
}

burkulesomesh43
Posts: 132
Joined: Tue Aug 14, 2018 6:21 am
Location: India

Re: Esp not connecting to wifi after some days

Postby burkulesomesh43 » Sun May 05, 2019 12:27 pm

reivax2 wrote:
Sat May 04, 2019 6:14 pm
WiFi.begin(ssid, password);
int i=0;
while (WiFi.status() != WL_CONNECTED && i++<=10)
{
delay(1000);
i=i+1;
if (i>11)
{Serial.print("I don´t connect......");
ESP.restart();
}
Sorry but I am not using arduino. and also its not the proper solution to restart esp.
--
Somesh Burkule

WiFive
Posts: 2787
Joined: Tue Dec 01, 2015 7:35 am

Re: Esp not connecting to wifi after some days

Postby WiFive » Mon May 06, 2019 7:08 am

Unfortunately it is hard to diagnose issue like this, you need logs from the time of disconnect. You can try with different esp-idf versions and different APs, see how common the problem is. You may even need WiFi sniffer captures to solve it.

burkulesomesh43
Posts: 132
Joined: Tue Aug 14, 2018 6:21 am
Location: India

Re: Esp not connecting to wifi after some days

Postby burkulesomesh43 » Mon May 06, 2019 7:35 am

WiFive wrote:
Mon May 06, 2019 7:08 am
Unfortunately it is hard to diagnose issue like this, you need logs from the time of disconnect. You can try with different esp-idf versions and different APs, see how common the problem is. You may even need WiFi sniffer captures to solve it.
As I saw logs w.r.t same issue, ESP32 gets connected to my Router with no IP (may be SYSTEM_EVENT_STA_GOT_IP event not generated) and it stucks until we switch it OFF and ON again. why does it happen. what is the reason behind it.


burkulesomesh43
Posts: 132
Joined: Tue Aug 14, 2018 6:21 am
Location: India

Re: Esp not connecting to wifi after some days

Postby burkulesomesh43 » Mon May 06, 2019 10:58 am

It is already enabled in my configuration by default.( CONFIG_LWIP_DHCP_DOES_ARP_CHECK ).
--
Somesh Burkule

WiFive
Posts: 2787
Joined: Tue Dec 01, 2015 7:35 am

Re: Esp not connecting to wifi after some days

Postby WiFive » Mon May 06, 2019 11:08 am

Enabled or disabled?

burkulesomesh43
Posts: 132
Joined: Tue Aug 14, 2018 6:21 am
Location: India

Re: Esp not connecting to wifi after some days

Postby burkulesomesh43 » Mon May 06, 2019 11:29 am

WiFive wrote:
Mon May 06, 2019 11:08 am
Enabled or disabled?
Sorry, It is enabled. I am going to disable it.
But really does it affect??
--
Somesh Burkule

burkulesomesh43
Posts: 132
Joined: Tue Aug 14, 2018 6:21 am
Location: India

Re: Esp not connecting to wifi after some days

Postby burkulesomesh43 » Thu May 30, 2019 6:28 am

I disbled this setting in menuconfig. but still getting same issue.
--
Somesh Burkule

Who is online

Users browsing this forum: MSN [Bot] and 21 guests