garbage serial out put - boot

sentinal8473
Posts: 2
Joined: Sat Jan 16, 2021 10:00 am

garbage serial out put - boot

Postby sentinal8473 » Sat Jan 16, 2021 1:23 pm

so I have two ESP32-DevKitC v4 kits....

I have having a ton of trouble trying to get the boot serial output.

I have tried screen in iTerm and terminal and Minicom on MacOS bigsur, and on KDE neon

I have tried all the baud rates, every time I reset the board I get garbage out (I am also unable to upload firmware), so trying to view the boot log to see what's going on....

see attached image

any ideas, I am at a complete loss.
Attachments
Screenshot 2021-01-14 at 8.03.17 AM.png
scrambled boot text
Screenshot 2021-01-14 at 8.03.17 AM.png (157.93 KiB) Viewed 447 times

chegewara
Posts: 1378
Joined: Wed Jun 14, 2017 9:00 pm

Re: garbage serial out put - boot

Postby chegewara » Sat Jan 16, 2021 3:43 pm

Did you try uart speed 115200, which is default esp32 speed?

sentinal8473
Posts: 2
Joined: Sat Jan 16, 2021 10:00 am

Re: garbage serial out put - boot

Postby sentinal8473 » Sun Jan 17, 2021 2:53 am

Hi,

I have tried 115200, and all the speeds in-between. Even an external serial to USB adapter with all the speeds, same results

ESP_Sprite
Posts: 4393
Joined: Thu Nov 26, 2015 4:08 am

Re: garbage serial out put - boot

Postby ESP_Sprite » Sun Jan 17, 2021 1:41 pm

That is odd... are you sure you have DevkitC's, and not e.g. Sparkfun ESP Thing, or some other board that use a different crystal? Apart from that' I'm scratching my head, you should get good output on 115200 baud.

Who is online

Users browsing this forum: No registered users and 31 guests