Welcome to the Official ESP32 forum!

User avatar
ESP_Admin
Site Admin
Posts: 5
Joined: Fri Nov 13, 2015 7:50 am

Welcome to the Official ESP32 forum!

Postby ESP_Admin » Fri Nov 13, 2015 11:25 am

We have closed the beta program for ESP32, and will be preparing to send out the demo boards.

sdavila
Posts: 1
Joined: Mon Sep 12, 2016 12:01 pm

Re: Welcome to the Official ESP32 forum!

Postby sdavila » Mon Sep 12, 2016 12:12 pm

H!

When do you think we´ll be able to buy the modules? and where can we do it?

Thanks!

capablegh
Posts: 1
Joined: Thu Sep 15, 2016 3:34 am

Re: Welcome to the Official ESP32 forum!

Postby capablegh » Thu Sep 15, 2016 3:41 am

I can see a few links to ESP32s on Aliexpress that seem to be available at this time. See this one link
https://www.aliexpress.com/item/2-pcs-l ... 32784.html

kv javali
Posts: 1
Joined: Thu Sep 01, 2016 12:22 pm

Re: Welcome to the Official ESP32 forum!

Postby kv javali » Sun Sep 18, 2016 6:36 am

Hi

what is the additional board managers url for ESP32 for Arduino

Thank you.

dipankarpanda
Posts: 4
Joined: Thu Nov 23, 2017 12:33 pm

Re: Welcome to the Official ESP32 forum!

Postby dipankarpanda » Mon Dec 11, 2017 11:52 am

Hi,
It may look a little stupid question, But I really wanted to know how to post a new question in the forum. I couldn't find any option... Please reply....

satishiot
Posts: 6
Joined: Fri Sep 22, 2017 11:29 am

Re: Welcome to the Official ESP32 forum!

Postby satishiot » Tue Dec 12, 2017 5:33 am

Hi dipankar

Check this link

viewforum.php?f=2

Look for new post and feel free to raise you doubts to the experts.

Cheers !! :)

Karan_26
Posts: 6
Joined: Fri Feb 23, 2018 11:40 am

ESP32 :After flashing , AT commands are not working

Postby Karan_26 » Fri Feb 23, 2018 12:30 pm

I am Working on ESP32 Module , I have successfully downloaded .bin file through ESP Flash Downloader Tool .
However I am unable to get the responses of AT Commands .
It seems like , ESP32 module is not initialising successful .

""phy_init: failed to load RF calibration data (0x1102), falling back to full calibration<ESC><CR><LF>""
Error is received on Debug log .
Please help me to solve this issue .

I have attached the debug log of ESP32 Initialisation process .

/*******************************************************************************/
23-02-2018 17:55:19.290 [RX] - <NUL>
23-02-2018 17:55:19.875 [RX] - ÿets Jun 8 2016 00:22:57<CR><LF>
<CR><LF>
rst:0x10 (RTCWDT_RTC_RESET),boot:0x1 (DOWNLOAD_BOOT(UART0/UART1/SDIO_FEI_REO_V2))<CR><LF>
waiting for download<CR><LF>

23-02-2018 17:55:23.969 [RX] - <ESC>I (14) boot: ESP-IDF v2.1-65-g8bca703 2nd stage bootloader<ESC><CR><LF>
<ESC>I (14) boot: compile time 07:53:05<ESC><CR><LF>
<ESC>I (15) boot: Enabling RNG early entropy source...<ESC><CR><LF>
<ESC>I (28) boot: SPI Speed : 40MHz<ESC><CR><LF>
<ESC>I (40) boot: SPI Mode : DIO<ESC><CR><LF>
<ESC>I (53) boot: SPI Flash Size : 4MB<ESC><CR><LF>
<ESC>I (65) boot: Partition Table:<ESC><CR><LF>
<ESC>I (76) boot: ## Label Usage Type ST Offset Length<ESC><CR><LF>
<ESC>I (98) boot: 0 phy_init RF data 01 01 0000f000 00001000<ESC><CR><LF>
<ESC>I (121) boot: 1 otadata OTA data 01 00 00010000 00002000<ESC><CR><LF>
<ESC>I (145) boot: 2 nvs WiFi data 01 02 00012000 0000e000<ESC><CR><LF>
<ESC>I (168) boot: 3 at_customize unknown 40 00 00020000 000e0000<ESC><CR><LF>
<ESC>I (191) boot: 4 ota_0 OTA app 00 10 00100000 00180000<ESC><CR><LF>
<ESC>I (214) boot: 5 ota_1 OTA app 00 11 00280000 00180000<ESC><CR><LF>
<ESC>I (238) boot: End of partition table<ESC><CR><LF>
<ESC>I (346) boot: Disabling RNG early entropy source...<ESC><CR><LF>
<ESC>I (346) boot: Loading app partition at offset 00100000<ESC><CR><LF>

23-02-2018 17:55:24.601 [RX] - <ESC>I (1958) boot: segment 0: paddr=0x00100018 vaddr=0x00000000 size=0x0ffe8 ( 65512) <ESC><CR><LF>
<ESC>I (1959) boot: segment 1: paddr=0x00110008 vaddr=0x3f400010 size=0x24a58 (150104) map<ESC><CR><LF>
<ESC>I (1975) boot: segment 2: paddr=0x00134a68 vaddr=0x3ffc0000 size=0x02e2c ( 11820) load<ESC><CR><LF>
<ESC>I (2007) boot: segment 3: paddr=0x0013789c vaddr=0x40080000 size=0x00400 ( 1024) load<ESC><CR><LF>
<ESC>I (2029) boot: segment 4: paddr=0x00137ca4 vaddr=0x40080400 size=0x11878 ( 71800) load<ESC><CR><LF>
<ESC>I (2089) boot: segment 5: paddr=0x00149524 vaddr=0x400c0000 size=0x00064 ( 100) load<ESC><CR><LF>
<ESC>I (2090) boot: segment 6: paddr=0x00149590 vaddr=0x00000000 size=0x06a78 ( 27256) <ESC><CR><LF>
<ESC>I (2113) boot: segment 7: paddr=0x00150010 vaddr=0x400d0018 size=0xc94d8 (824536) map<ESC><CR><LF>
<ESC>I (2140) cpu_start: Pro cpu up.<ESC><CR><LF>
<ESC>I (2151) cpu_start: Single core mode<ESC><CR><LF>
<ESC>I (2165) heap_alloc_caps: Initializing. RAM available for dynamic allocation:<ESC><CR><LF>
<ESC>I (2188) heap_alloc_caps: At 3FFAFF10 len 000000F0 (0 KiB): DRAM<ESC><CR><LF>
<ESC>I (2209) heap_alloc_caps: At 3FFB3000 len 00005000 (20 KiB): DRAM<ESC><CR><LF>
<ESC>I (2229) heap_alloc_caps: At 3FFBBB28 len 00002000 (8 KiB): DRAM<ESC><CR><LF>
<ESC>I (2250) heap_alloc_caps: At 3FFD2F00 len 0000D100 (52 KiB): DRAM<ESC><CR><LF>
<ESC>I (2271) heap_alloc_caps: At 3FFE0440 len 00003BC0 (14 KiB): D/IRAM<ESC><CR><LF>
<ESC>I (2292) heap_alloc_caps: At 3FFE4350 len 0001BCB0 (111 KiB): D/IRAM<ESC><CR><LF>
<ESC>I (2314) heap_alloc_caps: At 40091C78 len 0000E388 (56 KiB): IRAM<ESC><CR><LF>
<ESC>I (2335) cpu_start: Pro cpu start user code<ESC><CR><LF>
<ESC>I (2388) cpu_start: Starting scheduler on PRO CPU.<ESC><CR><LF>
<ESC>I (2611) uart: queue free spaces: 10<ESC><CR><LF>
Bin version(Wroom32):1.0.0<CR>
<CR><LF>
I (2615) wifi: wifi firmware version: 621ab6b<CR><LF>
I (2615) wifi: config NVS flash: enabled<CR><LF>
I (2615) wifi: config nano formating: disabled<CR><LF>
<ESC>I (2619) system_api: Base MAC address is not set, read default base MAC address from BLK0 of EFUSE<ESC><CR><LF>
<ESC>I (2629) system_api: Base MAC address is not set, read default base MAC address from BLK0 of EFUSE<ESC><CR><LF>
I (2652) wifi: Init dynamic tx buffer num: 32<CR><LF>
I (2652) wifi: Init dynamic rx buffer num: 32<CR><LF>
I (2653) wifi: wifi driver task: 3ffbd250, prio:23, stack:4096<CR><LF>
I (2655) wifi: Init static rx buffer num: 10<CR><LF>
I (2659) wifi: Init dynamic rx buffer num: 32<CR><LF>
I (2663) wifi: Init rx ampdu len mblock:7<CR><LF>
I (2667) wifi: Init lldesc rx ampdu entry mblock:4<CR><LF>
I (2671) wifi: wifi power manager task: 0x3ffdba2c prio: 21 stack: 2560<CR><LF>
I (2678) wifi: wifi timer task: 3ffdca94, prio:22, stack:3584<CR><LF>
<ESC>W (2683) phy_init: failed to load RF calibration data (0x1102), falling back to full calibration<ESC><CR><LF>
<ESC>I (2881) phy: phy_version: 362.1, 75758b5, Nov 1 2017, 16:02:06, 0, 2<ESC><CR><LF>
I (2889) wifi: mode : softAP (24:0a:c4:05:40:f5)<CR><LF>
I (2896) wifi: mode : sta (24:0a:c4:05:40:f4) + softAP (24:0a:c4:05:40:f5)<CR><LF>
I (2899) wifi: mode : softAP (24:0a:c4:05:40:f5)<CR><LF>

ESP_Sprite
Posts: 1848
Joined: Thu Nov 26, 2015 4:08 am

Re: Welcome to the Official ESP32 forum!

Postby ESP_Sprite » Sat Feb 24, 2018 7:18 am

This topic is no place for this. (Actually, this topic is pretty ancient in general; I'm locking it down.)

Who is online

Users browsing this forum: No registered users and 9 guests