Can‘t compile esp_idf?

xzwang
Posts: 22
Joined: Wed Dec 14, 2016 4:54 am

Can‘t compile esp_idf?

Postby xzwang » Mon Jun 12, 2017 9:20 am

hi,all,

I has update the esp_idf today, It has three months since last update. I try to compile the latest esp_idf but failed.
The error information is:
include/esp_assert.h:23:28: error: first argument to '__builtin_choose_expr' not a constant
_Static_assert(__builtin_choose_expr(__builtin_constant_p(CONDITION), (CONDITION), 1), #MSG); \

I have no idea how to fix the error.
Does anyone can give me some suggestion?

ESP_igrr
Posts: 1676
Joined: Tue Dec 01, 2015 8:37 am

Re: Can‘t compile esp_idf?

Postby ESP_igrr » Mon Jun 12, 2017 9:33 am

You probably need to update the toolchain (compiler), similar errors have been seen when compiling latest ESP-IDF with gcc 4.8.5.
Please follow the getting started guide for your platform to install new toolchain.

Who is online

Users browsing this forum: Baidu [Spider] and 34 guests