ESP32 Flashing stopped working

fancyusername0815
Posts: 1
Joined: Fri Oct 13, 2017 2:41 pm

ESP32 Flashing stopped working

Postby fancyusername0815 » Fri Oct 13, 2017 2:54 pm

Hi everyone!

I am using this ESP32 Dev Module:
https://shop.diy-dreams.de/products/esp32-developmentboard

For the last 2 Weeks i was using Arduino IDE. Everything worked fine.
I could flash my code using the 'esptool.py'.
Now i switched to using the xtensa toolchain and ESP IDF.
I successfully compiled and flashed the 'hello world' example from the ESP-IDF.

Unfortunately now my ESP can now not be flashed anymore!
Also running 'erase_flash' with esptool.py now gives me the output

Code: Select all

$ python esptool.py  --port/dev/tty.SLAB_USBtoUART erase_flash
esptool.py v2.1
Connecting........_____....._____....._____....._____....._____....._____....._____....._____....._____....._____

A fatal error occurred: Failed to connect to Espressif device: Timed out waiting for packet header


As i said, before flashing the 'hello_world' everything worked fine.
I am fully aware of the bootloader mode etc.. When i set it manually via the buttons, i can verify that it worked via Terminal:

Code: Select all

rst:0x1 (POWERON_RESET),boot:0x3 (DOWNLOAD_BOOT(UART0/UART1/SDIO_REI_REO_V2))
waiting for download


FYI: I am using Mac OS.

Can anyone help me getting my ESP to work again?

Who is online

Users browsing this forum: No registered users and 12 guests