play_mp3: codec init failed

zhaozh
Posts: 13
Joined: Mon Nov 25, 2019 2:22 pm

play_mp3: codec init failed

Postby zhaozh » Tue Nov 26, 2019 12:59 am

When I burn the code of play_mp3 again, it shows coder init failed. What is the reason for this? Could you please help me?

I (319) heap_init: At 40089EEC len 00016114 (88 KiB): IRAM
I (325) cpu_start: Pro cpu start user code
I (8) cpu_start: Chip Revision: 1
W (8) cpu_start: Chip revision is higher than the one configured in menuconfig.
Suggest to upgrade it.
I (11) cpu_start: Starting scheduler on PRO CPU.
I (0) cpu_start: Starting scheduler on APP CPU.
I (22) PLAY_MP3_FLASH: [ 1 ] Start audio codec chip
E (32) ES8388_DRIVER: es_write_reg error
E (32) ES8388_DRIVER: es_write_reg error
E (42) ES8388_DRIVER: es_write_reg error
E (42) ES8388_DRIVER: es_write_reg error
E (42) ES8388_DRIVER: es_write_reg error
E (52) ES8388_DRIVER: es_write_reg error
E (52) ES8388_DRIVER: es_write_reg error
E (62) ES8388_DRIVER: es_write_reg error
E (62) ES8388_DRIVER: es_write_reg error
E (72) ES8388_DRIVER: es_write_reg error
E (72) ES8388_DRIVER: es_write_reg error
E (82) ES8388_DRIVER: es_write_reg error
E (82) ES8388_DRIVER: es_write_reg error
E (92) ES8388_DRIVER: es_write_reg error
E (92) ES8388_DRIVER: es_write_reg error
E (92) ES8388_DRIVER: es_write_reg error
E (102) ES8388_DRIVER: es_write_reg error
E (102) ES8388_DRIVER: es_write_reg error
E (112) ES8388_DRIVER: es_write_reg error
E (112) ES8388_DRIVER: es_write_reg error
E (122) ES8388_DRIVER: es_write_reg error
E (122) ES8388_DRIVER: es_write_reg error
E (132) ES8388_DRIVER: es_write_reg error
E (132) ES8388_DRIVER: es_write_reg error
E (142) ES8388_DRIVER: es_write_reg error
E (142) AUDIO_HAL: codec init failed!
E (152) AUDIO_BOARD: D:/test3/msys32/home/Administrator/esp/esp-adf/components/a
udio_board/lyrat_v4_3/board.c:55 (audio_board_codec_init): Got NULL Pointer
E (162) AUDIO_HAL: audio_hal handle is null
I (172) PLAY_MP3_FLASH: [ 2 ] Create audio pipeline, add all elements to pipelin
e, and subscribe pipeline event
I (182) PLAY_MP3_FLASH: [2.1] Create mp3 decoder to decode mp3 file and set cust
om read callback
I (192) PLAY_MP3_FLASH: [2.2] Create i2s stream to write data to codec chip
I (202) PLAY_MP3_FLASH: [2.3] Register all elements to audio pipeline
I (202) PLAY_MP3_FLASH: [2.4] Link it together [mp3_music_read_cb]-->mp3_decoder
-->i2s_stream-->[codec_chip]
I (212) PLAY_MP3_FLASH: [ 3 ] Set up event listener
I (222) PLAY_MP3_FLASH: [3.1] Listening event from all elements of pipeline
I (222) PLAY_MP3_FLASH: [ 4 ] Start audio_pipeline
I (242) PLAY_MP3_FLASH: [ * ] Receive music info from mp3 decoder, sample_rates=
44100, bits=16, ch=2
I (6992) PLAY_MP3_FLASH: [ 5 ] Stop audio_pipeline
W (7002) AUDIO_ELEMENT: [mp3] Element already stopped
W (7002) AUDIO_ELEMENT: [i2s] Element already stopped
W (7002) AUDIO_PIPELINE: audio_pipeline state is not running, 1
W (7012) AUDIO_PIPELINE: audio_pipeline state is not running, 1
W (7012) AUDIO_PIPELINE: audio_pipeline state is not running, 1
W (7022) AUDIO_PIPELINE: There are no listener registered
W (7032) AUDIO_ELEMENT: [i2s] Element has not create when AUDIO_ELEMENT_TERMINAT
E
W (7042) AUDIO_ELEMENT: [mp3] Element has not create when AUDIO_ELEMENT_TERMINAT
E
W (8162) HEADPHONE: Headphone jack inserted
W (9162) HEADPHONE: Headphone jack removed

ESP_Sprite
Posts: 3603
Joined: Thu Nov 26, 2015 4:08 am

Re: play_mp3: codec init failed

Postby ESP_Sprite » Tue Nov 26, 2019 2:26 am

I renamed your post, as 'can everyone help me' is not that useful. What hardware are you using? Did you modify anything on the board, or connect anything to it?

zhaozh
Posts: 13
Joined: Mon Nov 25, 2019 2:22 pm

Re: play_mp3: codec init failed

Postby zhaozh » Tue Nov 26, 2019 2:46 am

I used esp32-lyra and I ran "hello world" once before.

Who is online

Users browsing this forum: No registered users and 1 guest