Azure IoT SDK and inclusion errors

Posts: 2
Joined: Tue Oct 08, 2019 1:48 pm

Azure IoT SDK and inclusion errors

Postby afcec1 » Tue Oct 08, 2019 3:35 pm


I have successfully set up Eclipse for ESP development following the information provided in the link from below (ESP-IDF 4.0 beta1, Eclipse 2019-09 R 4.13.0): ... /

It works just fine with several ESP-IDF examples (I can build and flash on ESP32) but then I tried to run also a mqtt client example (iothub_client_sample_mqtt) included with ESP-AZURE(last azure-iot-SDK-c available) and I am experiencing some problems with inclusion errors (iothub_client.h). I obviously have checked that the header file is present and I can even navigate to it using 'Open Declaration' option on the #include.

I have been searching the web and it looks like this problem is quite old. However I have tried several different solutions suggested with no success.

Is there anything I can do to fix this problem? I have wide experience with several different programming languages and development platforms but I am new to Eclipse and I am just struggling with every single step required to set up the system when the predefined procedures do not work.

Thanks in advance

Who is online

Users browsing this forum: No registered users and 1 guest