ESP IDF tools安装问题

L_T_C_
Posts: 1
Joined: Fri Jan 21, 2022 3:48 pm

ESP IDF tools安装问题

Postby L_T_C_ » Fri Jan 21, 2022 3:54 pm

小白,目前在配置环境。每次安装 idf tools时,总会由于一下报错失败:

Installing Python packages from E:\ESP\esp-idf-v4.3.2\requirements.txt
Looking in indexes: https://mirrors.aliyun.com/pypi/simple/, https://dl.espressif.com/pypi, https://dl.espressif.com/pypi
Ignoring cffi: markers 'python_version < "3.6"' don't match your environment
Requirement already satisfied: setuptools>=21 in c:\users\admin\.espressif\python_env\idf4.3_py3.8_env\lib\site-packages (from -r E:\ESP\esp-idf-v4.3.2\requirements.txt (line 4)) (51.3.3)


之前好像网上看到 Python3.8 比较适配,低于3.8不行,3.9+也还不支持。这边为什么会有<3.6的要求呀?

求解答,已经困扰快一周了

ESP_ICY
Posts: 348
Joined: Mon Aug 23, 2021 11:10 am

Re: ESP IDF tools安装问题

Postby ESP_ICY » Tue Jan 25, 2022 9:56 am

提供一下完整的 log ,然后简单描述下你安装的流程和 idf版本吧

Kevin_WWW
Posts: 7
Joined: Tue Feb 01, 2022 7:52 am

Re: ESP IDF tools安装问题

Postby Kevin_WWW » Tue Feb 01, 2022 8:19 am

检查所有与python3.6有关的PATH

Who is online

Users browsing this forum: No registered users and 18 guests