VS Code Extension rejects Python 3.9?

kevin1
Posts: 7
Joined: Wed Oct 14, 2020 7:04 am

VS Code Extension rejects Python 3.9?

Postby kevin1 » Thu Oct 22, 2020 2:09 am

First window entered: C:\Users\kevin\AppData\Local\Programs\Python\Python39\python.exe
Next:
ESP-IDF-TOOLS3.png
ESP-IDF-TOOLS3.png (22.11 KiB) Viewed 617 times
Next:
ESP-IDF-TOOLS4.png
ESP-IDF-TOOLS4.png (71.91 KiB) Viewed 617 times
Next:
ESP-IDF-TOOLS.png
ESP-IDF-TOOLS.png (72.63 KiB) Viewed 617 times
Fails:
Command failed: "C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe" "c:\Users\kevin\esp\esp-idf\tools\check_python_dependencies.py" -r "c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt"

Python 3.9 is accepted when installing esp-idf tools via install.bat
Please advise.
Kevin

kevin1
Posts: 7
Joined: Wed Oct 14, 2020 7:04 am

Re: VS Code Extension rejects Python 3.9?

Postby kevin1 » Thu Oct 22, 2020 4:42 pm

Previously I installed esp-idf as shown in the text file:
Issue 21102020 5994.txt
(47.55 KiB) Downloaded 23 times
The text file shows the final install/configuration.
This is part of https://github.com/espressif/esp-idf/issues/5994

ESP_bignacio
Posts: 31
Joined: Wed May 02, 2018 12:12 pm

Re: VS Code Extension rejects Python 3.9?

Postby ESP_bignacio » Fri Oct 23, 2020 12:22 pm

There seems to be some issue with debug adapter requirements and Python 3.9

Can you try python c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt and see if you get any error ?

Also please share the extension log in

- Windows: `%USERPROFILE%\.vscode\extensions\espressif.esp-idf-extension-VERSION\esp_idf_vsc_ext.log`
- Linux & MacOSX: `$HOME/.vscode/extensions/espressif.esp-idf-extension-VERSION/esp_idf_vsc_ext.log`

kevin1
Posts: 7
Joined: Wed Oct 14, 2020 7:04 am

Re: VS Code Extension rejects Python 3.9?

Postby kevin1 » Sat Oct 24, 2020 3:15 am

Code: Select all

click             Y
psutil>=5.5.1     N
pygdbmi<=0.9.0.2  Y
requests>=2.21.0  N
typing>=3.6.6     N
xmlrunner>=1.7.7  N
=======================================
C:\Users\kevin\esp>pip install "psutil>=5.5.1"
Collecting psutil>=5.5.1
  Downloading psutil-5.7.2.tar.gz (460 kB)
     |████████████████████████████████| 460 kB 819 kB/s
Building wheels for collected packages: psutil
  Building wheel for psutil (setup.py) ... done
  Created wheel for psutil: filename=psutil-5.7.2-cp39-cp39-win_amd64.whl size=244174 sha256=e392d220b9056d236a884cb64d9e7992a265033935b29774425e1af11b599571
  Stored in directory: c:\users\kevin\appdata\local\pip\cache\wheels\5d\fd\59\996857f9128ee706989567c761b9aa449f2d5d99435944d5be
Successfully built psutil
Installing collected packages: psutil
Successfully installed psutil-5.7.2
WARNING: You are using pip version 20.2.3; however, version 20.2.4 is available.
You should consider upgrading via the 'C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe -m pip install --upgrade pip' command.

C:\Users\kevin\esp>pip install "requests>=2.21.0"
Collecting requests>=2.21.0
  Using cached requests-2.24.0-py2.py3-none-any.whl (61 kB)
Collecting chardet<4,>=3.0.2
  Using cached chardet-3.0.4-py2.py3-none-any.whl (133 kB)
Collecting certifi>=2017.4.17
  Using cached certifi-2020.6.20-py2.py3-none-any.whl (156 kB)
Collecting idna<3,>=2.5
  Using cached idna-2.10-py2.py3-none-any.whl (58 kB)
Collecting urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1
  Downloading urllib3-1.25.11-py2.py3-none-any.whl (127 kB)
     |████████████████████████████████| 127 kB 819 kB/s
Installing collected packages: chardet, certifi, idna, urllib3, requests
Successfully installed certifi-2020.6.20 chardet-3.0.4 idna-2.10 requests-2.24.0 urllib3-1.25.11
WARNING: You are using pip version 20.2.3; however, version 20.2.4 is available.
You should consider upgrading via the 'C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe -m pip install --upgrade pip' command.

C:\Users\kevin\esp>pip install "typing>=3.6.6"
Collecting typing>=3.6.6
  Using cached typing-3.7.4.3.tar.gz (78 kB)
Building wheels for collected packages: typing
  Building wheel for typing (setup.py) ... done
  Created wheel for typing: filename=typing-3.7.4.3-py3-none-any.whl size=26312 sha256=4326cb466b90e58736ea5fe1022bcfd1c9a2850e16a8b9bef1344b687f298487
  Stored in directory: c:\users\kevin\appdata\local\pip\cache\wheels\fa\17\1f\332799f975d1b2d7f9b3f33bbccf65031e794717d24432caee
Successfully built typing
Installing collected packages: typing
Successfully installed typing-3.7.4.3
WARNING: You are using pip version 20.2.3; however, version 20.2.4 is available.
You should consider upgrading via the 'C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe -m pip install --upgrade pip' command.

C:\Users\kevin\esp>pip install "xmlrunner>=1.7.7"
Collecting xmlrunner>=1.7.7
  Using cached xmlrunner-1.7.7.tar.gz (5.6 kB)
Building wheels for collected packages: xmlrunner
  Building wheel for xmlrunner (setup.py) ... done
  Created wheel for xmlrunner: filename=xmlrunner-1.7.7-py3-none-any.whl size=6239 sha256=13a9934bbac7587afcfdfa1f0ecf5b4e6c0af7ac17fb7aac5d51a964a767c1d5
  Stored in directory: c:\users\kevin\appdata\local\pip\cache\wheels\c0\1c\a1\b05ae749aa485a55d20886d4973333f3f83db8969ccc9c36b4
Successfully built xmlrunner
Installing collected packages: xmlrunner
Successfully installed xmlrunner-1.7.7
WARNING: You are using pip version 20.2.3; however, version 20.2.4 is available.
You should consider upgrading via the 'C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe -m pip install --upgrade pip' command.

C:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_idf_vsc_ext.log

pip3 install -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt

C:\Users\kevin\esp\hello_world>pip3 install -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt
Requirement already satisfied: click in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 1)) (7.1.2)
Requirement already satisfied: psutil>=5.5.1 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 2)) (5.7.2)
Requirement already satisfied: pygdbmi<=0.9.0.2 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 3)) (0.9.0.2)
Requirement already satisfied: requests>=2.21.0 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 4)) (2.24.0)
Requirement already satisfied: typing>=3.6.6 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 5)) (3.7.4.3)
Requirement already satisfied: xmlrunner>=1.7.7 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from -r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 6)) (1.7.7)
Requirement already satisfied: chardet<4,>=3.0.2 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from requests>=2.21.0->-r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 4)) (3.0.4)
Requirement already satisfied: idna<3,>=2.5 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from requests>=2.21.0->-r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 4)) (2.10)
Requirement already satisfied: certifi>=2017.4.17 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from requests>=2.21.0->-r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 4)) (2020.6.20)
Requirement already satisfied: urllib3!=1.25.0,!=1.25.1,<1.26,>=1.21.1 in c:\users\kevin\.espressif\python_env\idf4.3_py3.9_env\lib\site-packages (from requests>=2.21.0->-r c:\Users\kevin\.vscode\extensions\espressif.esp-idf-extension-0.5.1\esp_debug_adapter\requirements.txt (line 4)) (1.25.11)
WARNING: You are using pip version 20.2.3; however, version 20.2.4 is available.
You should consider upgrading via the 'C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe -m pip install --upgrade pip' command.
Attachments
esp_idf_vsc_ext.log
(40.34 KiB) Downloaded 20 times

kevin1
Posts: 7
Joined: Wed Oct 14, 2020 7:04 am

Re: VS Code Extension rejects Python 3.9?

Postby kevin1 » Sat Oct 24, 2020 6:45 am

@ESP_bignacio
ESP-IDF-TOOLS5.png
ESP-IDF-TOOLS5.png (80.83 KiB) Viewed 524 times
Success with esp-idf

COM ports will not list?
USB1.png
USB1.png (27.26 KiB) Viewed 524 times
Python 3.8 should not appear? Should be:
C:\Users\kevin\.espressif\python_env\idf4.3_py3.9_env\Scripts\python.exe
Python 3.9
See below:
VSCode1.png
VSCode1.png (197.59 KiB) Viewed 524 times
Have problem with
C:\Users\kevin\.espressif\tools\xtensa-esp32s2-elf\esp-2020r3-8.4.0\xtensa-esp32s2-elf\xtensa-esp32s2-elf\include\reent.h
How do I add this to include paths?

Many thanks,
Kevin

ESP_bignacio
Posts: 31
Joined: Wed May 02, 2018 12:12 pm

Re: VS Code Extension rejects Python 3.9?

Postby ESP_bignacio » Tue Oct 27, 2020 1:58 am

You need to configure the Microsoft C/C++ extension c_cpp_properties.json as shown here https://github.com/espressif/vscode-esp ... URATION.md

Who is online

Users browsing this forum: No registered users and 1 guest