ESP32 debugging with Segger Jlink

Karim1993
Posts: 20
Joined: Mon Aug 27, 2018 4:28 am

Re: ESP32 debugging with Segger Jlink

Postby Karim1993 » Thu Nov 01, 2018 8:17 am

ESP32 debugging with Segger JLink worked fine for me an Ubuntu 14.04 machine with the binaries provided. I just faced the issue with clock frequency which was later resolved.

ningappa BS
Posts: 51
Joined: Sat Mar 17, 2018 4:49 am

Re: ESP32 debugging with Segger Jlink

Postby ningappa BS » Fri Nov 02, 2018 4:26 am

Could you please first verify if you are able to debug from the command line, before using Eclipse? Please follow these instructions: https://docs.espressif.com/projects/esp ... index.html
you mean that "GDB debugging".

ningappa BS
Posts: 51
Joined: Sat Mar 17, 2018 4:49 am

Re: ESP32 debugging with Segger Jlink

Postby ningappa BS » Fri Nov 02, 2018 4:33 am

ESP32 debugging with Segger JLink worked fine for me an Ubuntu 14.04 machine with the binaries provided. I just faced the issue with clock frequency which was later resolved.
could you please share the steps you have followed because am getting errors which you can check in this conversation.

thanks

Karim1993
Posts: 20
Joined: Mon Aug 27, 2018 4:28 am

Re: ESP32 debugging with Segger Jlink

Postby Karim1993 » Mon Nov 05, 2018 12:11 pm

I built the openocd from source by following steps from https://docs.espressif.com/projects/esp ... linux.html

Then the command openocd -s . -f interface/jlink.cfg -f board/esp-wroom-32.cfg

Thanks,
Karim

ningappa BS
Posts: 51
Joined: Sat Mar 17, 2018 4:49 am

Re: ESP32 debugging with Segger Jlink

Postby ningappa BS » Thu Nov 22, 2018 4:30 am

Karim1993 wrote:
Mon Nov 05, 2018 12:11 pm
I built the openocd from source by following steps from https://docs.espressif.com/projects/esp ... linux.html

Then the command openocd -s . -f interface/jlink.cfg -f board/esp-wroom-32.cfg

Thanks,
Karim
Hi,
i followed the procedure which you have given in the link
Steps followed....

step 1-----> cd ~/esp
step 2-----> git clone --recursive https://github.com/espressif/openocd-esp32.git
step 3-----> sudo apt-get install make
sudo apt-get install libtool
sudo apt-get install pkg-config
sudo apt-get install autoconf
sudo apt-get install automake
sudo apt-get install texinfo
sudo apt-get install libusb-1.0
step 4-----> cd ~/esp/openocd-esp32
./bootstrap
./configure
make

step 5----->openocd -s . -f interface/jlink.cfg -f board/esp-wroom-32.cfg

this is what am getting
"Warn : Unexpected idcode after end of chain: 627 0x00000000
Error: double-check your JTAG setup (interface, speed, ...)
Error: Trying to use configured scan chain anyway...
Warn : AUTO auto0.tap - use "jtag newtap auto0 tap -irlen 2 -expected-id 0x00000000"
Error: auto0.tap: IR capture error; saw 0x0000 not 0x0001
Warn : Bypassing JTAG setup events due to errors
cpu0: Current bits set: none
cpu1: Current bits set: none"

Correct me if I am wrong and any suggestions on where I am going wrong is welcome.
let me know how to solve this.

thanks

User avatar
arunbm123
Posts: 96
Joined: Fri Feb 23, 2018 5:36 am

Re: ESP32 debugging with Segger Jlink

Postby arunbm123 » Tue Dec 18, 2018 2:51 pm

hi Ningappa BS

Are you able to debug with Openocd and JTAG ?
-Arun

User avatar
arunbm123
Posts: 96
Joined: Fri Feb 23, 2018 5:36 am

Re: ESP32 debugging with Segger Jlink

Postby arunbm123 » Tue Dec 18, 2018 2:53 pm

hello Ningappa

I am getting

$ bin/openocd.exe -s -f interface/jlink.cfg -f board/esp-wroom-32.cfg

Open On-Chip Debugger 0.10.0-dev (2018-11-05-04:10)
Licensed under GNU GPL v2
For bug reports, read
http://openocd.org/doc/doxygen/bugs.html
embedded:startup.tcl:60: Error: Can't find board/esp-wroom-32.cfg
in procedure 'script'
at file "embedded:startup.tcl", line 60

ningappa BS
Posts: 51
Joined: Sat Mar 17, 2018 4:49 am

Re: ESP32 debugging with Segger Jlink

Postby ningappa BS » Tue Jan 15, 2019 7:47 am

hi,

i am using olimax debugger, it is working.


thanks,

Who is online

Users browsing this forum: No registered users and 34 guests