ESP32-Wrover doesn't flash

linuxfpv
Posts: 7
Joined: Sun Jan 13, 2019 12:17 pm

ESP32-Wrover doesn't flash

Postby linuxfpv » Sat May 25, 2019 8:27 am

Hello all,

I'm a bit clueless, about my project.
The problem is, that I can't flash my ESP, even worse, I can't communicate with it, e.g. esptool.py chip_id is not working, then I get the error "All of the 4 available serial ports could not connect to a Espressif device." So in my eyes, for this command, the flash settings are irrelevant, aren't they?
As this page states, to get into the bootloader mode, you only need to tie gpio0 to ground.
https://github.com/espressif/esptool/wi ... -Selection

Maybe you can have a look on my schematic, wether i forgot something.
I used this chip: https://www.conrad.de/de/p/wi-fi-bt-ble ... 25470.html, which should be a ESP32-Wrover.
And yes, I already measured the VCC and the ground pin, the esp should get voltage.

Thanks in advance,
Linus

WiFive
Posts: 2690
Joined: Tue Dec 01, 2015 7:35 am

Re: ESP32-Wrover doesn't flash

Postby WiFive » Sat May 25, 2019 9:55 am

What schematic?

linuxfpv
Posts: 7
Joined: Sun Jan 13, 2019 12:17 pm

Re: ESP32-Wrover doesn't flash

Postby linuxfpv » Sat May 25, 2019 11:03 am

Sry, it didn't upload, here it should be now.
Attachments
Schematic_flightcontroller_Sheet-1_20190525101919.pdf
(57.63 KiB) Downloaded 44 times

ESP_Sprite
Posts: 2832
Joined: Thu Nov 26, 2015 4:08 am

Re: ESP32-Wrover doesn't flash

Postby ESP_Sprite » Sat May 25, 2019 11:47 am

Suggest you double-check the datasheet of your module, especially compare to chapter 7. If anything, you can see you're leaving the /EN pin flapping in the breeze; you need a RC network there and you need a way to pull it low when you need to program the thing.

linuxfpv
Posts: 7
Joined: Sun Jan 13, 2019 12:17 pm

Re: ESP32-Wrover doesn't flash

Postby linuxfpv » Sat May 25, 2019 12:49 pm

Ok, I assumed, that I can also just pull GPIO0 to low, when I power the chip. I will try, pulling also Enable on low.

linuxfpv
Posts: 7
Joined: Sun Jan 13, 2019 12:17 pm

Re: ESP32-Wrover doesn't flash

Postby linuxfpv » Sat May 25, 2019 1:47 pm

Ok, it works now!!! Thank u very much!

Who is online

Users browsing this forum: No registered users and 6 guests