[solved] rtcwdt_rtc_reset not appearing - not connecting to WiFi.

kmmaran
Posts: 19
Joined: Tue Oct 23, 2018 6:20 am

[solved] rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby kmmaran » Sat Jul 20, 2019 6:24 am

Hi Experts,

I am RF/Hardware Engineer trying to get into embedded world, my apology for any error on below request.
I am trying to connect my board to WiFi access point. I have built my own custom board, everything working well, but the WiFi can't connect to access point. I tried on Wemos Lolin Light and seems to be working on same code. I have checked the hardware, connect up to spectrum analyser and board is transmitting around same RF level but can't connect to access point. I have attached here my board and Wemos board details from monitor. Also checked, clock, voltages, decoupling.

The different from serial messages from custom board and Wemos is
rtcwdt_rtc_reset not appearing in custom board. Why rtcwdt_rtc_reset not appearing, I cannot understand this?

I have tried on BLE as well, same issue.

My Sketch

[Codebox]#include "WiFi.h"

const char* ssid = "Not Shown";
const char* password = "Not Shown";

void setup() {

Serial.begin(115200);

WiFi.begin(ssid, password);

while (WiFi.status() != WL_CONNECTED) {
delay(500);
Serial.println("Connecting to WiFi..");
}

Serial.println("Connected to the WiFi network");

}

void loop() {}[/Codebox]

Serial Monitor Output

**Message from custom board**


ets Jun 8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:928
ho 0 tail 12 room 4
load:0x40078000,len:8424
ho 0 tail 12 room 4
load:0x40080400,len:5868
entry 0x4008069c
Connecting to WiFi..
Connecting to WiFi..
Connecting to WiFi..

**Message from Wemos board**

ets Jun 8 2016 00:22:57

rst:0x1 (POWERON_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
ets Jun 8 2016 00:22:57

rst:0x10 (RTCWDT_RTC_RESET),boot:0x13 (SPI_FAST_FLASH_BOOT)
configsip: 0, SPIWP:0xee
clk_drv:0x00,q_drv:0x00,d_drv:0x00,cs0_drv:0x00,hd_drv:0x00,wp_drv:0x00
mode:DIO, clock div:1
load:0x3fff0018,len:4
load:0x3fff001c,len:928
ho 0 tail 12 room 4
load:0x40078000,len:8424
ho 0 tail 12 room 4
load:0x40080400,len:5868
entry 0x4008069c
Connecting to WiFi..
Connecting to WiFi..
Connected to the WiFi network
Last edited by kmmaran on Tue Aug 20, 2019 3:31 pm, edited 1 time in total.

WiFive
Posts: 2822
Joined: Tue Dec 01, 2015 7:35 am

Re: rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby WiFive » Sat Jul 20, 2019 8:26 am

Wemos board has old chip version which has this bug

For wifi check viewtopic.php?f=12&t=11050

kmmaran
Posts: 19
Joined: Tue Oct 23, 2018 6:20 am

Re: rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby kmmaran » Sat Jul 20, 2019 10:34 am

Thanks @WiFive for the reference.

The issue is with my custom board. Wemos board is good.
I have looked at the crystal and 40MHz (sometime +/- 0.5KHz) similar to Wemos board.
Last edited by kmmaran on Sat Jul 20, 2019 1:30 pm, edited 1 time in total.

kmmaran
Posts: 19
Joined: Tue Oct 23, 2018 6:20 am

Re: rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby kmmaran » Sat Jul 20, 2019 1:29 pm

Hi @WiFive,

After reading again the reference post, I will again check the crystal, +/-0.5KHz is way off +/-10PPM for 40MHz.

Now I understand why rtcwdt_rtc_reset only appearing in Wemos, because its a old version.

Thank you for your help.

kmmaran
Posts: 19
Joined: Tue Oct 23, 2018 6:20 am

Re: rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby kmmaran » Tue Jul 23, 2019 10:01 pm

Hi @WiFive,

The problem now solved. The issue is related to crystal, sitting on the pad but dry joint, the peak to peak voltage is lower compare to Wemos. Thank you for your reference.

kmmaran
Posts: 19
Joined: Tue Oct 23, 2018 6:20 am

Re: rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby kmmaran » Tue Jul 23, 2019 10:04 pm

Sorry how to close this post.

WiFive
Posts: 2822
Joined: Tue Dec 01, 2015 7:35 am

Re: rtcwdt_rtc_reset not appearing - not connecting to WiFi.

Postby WiFive » Wed Jul 24, 2019 12:58 am

Just put [Solved] in the title

Who is online

Users browsing this forum: No registered users and 21 guests