unreliable wifi on custom hardware

imtiaz
Posts: 106
Joined: Wed Oct 26, 2016 1:34 am

unreliable wifi on custom hardware

Postby imtiaz » Thu Nov 09, 2017 8:45 pm

Hi @ESP_Angus , @WiFive , @ESP_SPRITE,@ESP_igrr

We have a custom esp module and are finding a few issues with the wifi connection . We have been struggling with it for the past few days and thought to ask here in case you guys can give us an insight into what the root cause could be. Here are what we are seeing:

The same code works fine on the WRover kit.
1 - The wifi access point gets created but it either cannot be connected to takes several tries .
2 - As a station it seems more reliable - however sometimes it fails to connect

Here is a log output of an access point when it is failing to connect.It seems like it keeps connecting and disconnecting and finally either is succesfull or fails. When we try again it generally works .
  • I (625958) wifi: n:1 0, o:1 0, ap:1 1, sta:255 255, prof:1<\r><\n>
    I (625958) wifi: station: 64:89:9a:31:38:d3 join, AID=2, g, 20<\r><\n>
    <27>[0;32mI (625960) wifi: wifi event : 15<\r><\n>
    <27>[0m<\r><\n>
    I (626278) wifi: n:1 0, o:1 0, ap:1 1, sta:255 255, prof:1<\r><\n>
    I (626278) wifi: station: 64:89:9a:31:38:d3 join, AID=2, g, 20<\r><\n>
    <27>[0;32mI (626280) wifi: wifi event : 15<\r><\n>
    <27>[0m<\r><\n>
    I (626598) wifi: n:1 0, o:1 0, ap:1 1, sta:255 255, prof:1<\r><\n>
    I (626599) wifi: station: 64:89:9a:31:38:d3 join, AID=2, g, 20<\r><\n>
    <27>[0;32mI (626600) wifi: wifi event : 15<\r><\n>
    <27>[0m<\r><\n>
    I (626917) wifi: n:1 0, o:1 0, ap:1 1, sta:255 255, prof:1<\r><\n>
    I (626917) wifi: station: 64:89:9a:31:38:d3 join, AID=2, g, 20<\r><\n>
    <27>[0;32mI (626919) wifi: wifi event : 15<\r><\n>
    <27>[0m<\r><\n>
    I (627235) wifi: n:1 0, o:1 0, ap:1 1, sta:255 255, prof:1<\r><\n>
    I (627235) wifi: station: 64:89:9a:31:38:d3 join, AID=2, g, 20<\r><\n>
    <27>[0;32mI (627236) wifi: wifi event : 15<\r><\n>
    <27>[0m<\r><\n>
    I (627552) wifi: n:1 0, o:1 0, ap:1 1, sta:255 255, prof:1<\r><\n>
    I (627552) wifi: station: 64:89:9a:31:38:d3 join, AID=2, g, 20<\r><\n>
    <27>[0;32mI (627554) wifi: wifi event : 15<\r><\n>
[/list]


Our hardware is essentially the same except for these few differences:
1 - we are using a chip antennae (attached specs)
2 - different crystal and load caps (the frequency is +0.8kHz offset from 40MHz)
3 - The PI matching network is different as the antenna we are using is different. We have matched the antenna manually resulting in the match network you see in the schematic.

By the way the RF power output from the module is comparable or better than the esp WRover kit.


Any help /ideas would be highly appreciated
Regards
Imtiaz
Attachments
module.PNG
module.PNG (117.85 KiB) Viewed 1805 times
antenna.PNG
antenna.PNG (83.83 KiB) Viewed 1805 times

Lucas.Hutchinson
Posts: 79
Joined: Tue Apr 26, 2016 5:10 am

Re: unreliable wifi on custom hardware

Postby Lucas.Hutchinson » Wed Nov 22, 2017 2:34 am

Just checking if anyone has any thoughts on this?

ESP_igrr
Posts: 1675
Joined: Tue Dec 01, 2015 8:37 am

Re: unreliable wifi on custom hardware

Postby ESP_igrr » Wed Nov 22, 2017 4:57 am

For RF matching issues, it is best to contact Espressif via sales@espressif.com. Testing and optimization of customer hardware can be arranged (you will need to send us the board). Things like this a fairly hard to troubleshoot on the forum, plus the three ESP_ engineers tagged in the first post are definitely not the ones to seek advice from on RF related issues.

Who is online

Users browsing this forum: No registered users and 26 guests