esp-wroom-32 deep sleep current

noblerabbit
Posts: 6
Joined: Tue Oct 23, 2018 9:49 am

esp-wroom-32 deep sleep current

Postby noblerabbit » Sun Dec 23, 2018 8:18 pm

Hi,

I made a breakout board and right now it only contains esp-wroom-32 with TX, RX connectors (i have SIL 2102 on separate pcb for us communication) so i can communicate with it.

If I put esp-wroom-32 in deep sleep the current is 470 uA. Whatever is driving the current must be inside the wroom. I've seen reports some people achieved 50 uA in deep sleep on wroom. Are there any GPIOs I should force to low in order to reduce the current in deepsleep?

Thanks!

ntldr2018
Posts: 3
Joined: Mon Dec 24, 2018 4:28 am

Re: esp-wroom-32 deep sleep current

Postby ntldr2018 » Mon Dec 24, 2018 4:35 am

Where exactly are you measuring the current? You might be also measuring your 2102 as well if you measure the full input current. Also there are a couple of different ways to put the ESP32 to sleep. How exactly are you making it sleep?

For a "naked" WROOM32 I've gotten my multimeter to show 0.1mA just by normally starting a deep sleep. (Sadly measuring µA doesn't work due to too high of a shunt resistance in my multimeter causing the voltage to drop below 2V.).

User avatar
loboris
Posts: 514
Joined: Wed Dec 21, 2016 7:40 pm

Re: esp-wroom-32 deep sleep current

Postby loboris » Mon Dec 24, 2018 9:42 am

ESP-WROOM32 should have only 5 uA current in deepsleep.
How are you powering it?

noblerabbit
Posts: 6
Joined: Tue Oct 23, 2018 9:49 am

Re: esp-wroom-32 deep sleep current

Postby noblerabbit » Wed Dec 26, 2018 4:56 pm

Hi,
Thanks for the fast reply. I stand corrected (I had accelerometer connected). esp-wroom-32 deepsleep current stands as 4.6 uA. I am using KeySight 34461A. Power supply 3.3V + pin > 34461A > 3v3 input on PCB with wroom.
Thanks.

balujayatin
Posts: 2
Joined: Thu Jan 31, 2019 7:45 am

Re: esp-wroom-32 deep sleep current

Postby balujayatin » Thu Jan 31, 2019 7:50 am

#define uS_TO_S_FACTOR 1000000 /* Conversion factor for micro seconds to seconds */
#define TIME_TO_SLEEP 3 /* Time ESP32 will go to sleep (in seconds) */

RTC_DATA_ATTR int bootCount = 0;

int GREEN_LED_PIN = 25;
int YELLOW_LED_PIN = 26;

void setup(){

pinMode(GREEN_LED_PIN,OUTPUT);
pinMode(YELLOW_LED_PIN,OUTPUT);
delay(500);

if(bootCount == 0) //Run this only the first time
{
digitalWrite(YELLOW_LED_PIN,HIGH);
bootCount = bootCount+1;
}else
{
digitalWrite(GREEN_LED_PIN,HIGH);
}

delay(3000);

digitalWrite(GREEN_LED_PIN,LOW);
digitalWrite(YELLOW_LED_PIN,LOW);

esp_sleep_enable_timer_wakeup(TIME_TO_SLEEP * uS_TO_S_FACTOR);
esp_deep_sleep_start();
}

void loop(){

}
Hi All,

I'm using this code to reduce the current or to enter the deep sleep mode but after deploying I'm still getting 9.1mA consumption. It is not entering into microAmp. Please suggest how I can achieve that parameter.

Regards,
Yatin

Who is online

Users browsing this forum: ESP_Roland and 19 guests